diff mbox series

[meta-python,15/30] python3-pydantic: upgrade 2.7.0 -> 2.7.1

Message ID 20240502144829.241208-15-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-networking,01/30] fping: upgrade 5.1 -> 5.2 | expand

Commit Message

Mingyu Wang (Fujitsu) May 2, 2024, 2:48 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Bump pydantic-core to v2.18.2
-Ftp and Websocket connection strings support
-Use field description for RootModel schema description when there is no docstring
-Fix validation_alias behavior with model_construct for AliasChoices and AliasPath
-Revert typing.Literal and import it outside the TYPE_CHECKING block
-Fix Secret serialization schema, applicable for unions
-Fix strict application to function-after with use_enum_values
-Address case where model_construct on a class which defines model_post_init fails with AttributeError
-Fix model_json_schema with config types
-Support multiple zeros as an int
-Fix validation of ints with leading unary plus
-Fix interaction between extra != 'ignore' and from_attributes=True
-Handle error from Enum's missing function as ValidationError
-Fix memory leak with Iterable validation

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pydantic_2.7.0.bb => python3-pydantic_2.7.1.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pydantic_2.7.0.bb => python3-pydantic_2.7.1.bb} (95%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic_2.7.0.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.7.1.bb
similarity index 95%
rename from meta-python/recipes-devtools/python/python3-pydantic_2.7.0.bb
rename to meta-python/recipes-devtools/python/python3-pydantic_2.7.1.bb
index 36ad83527..3c1114447 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic_2.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic_2.7.1.bb
@@ -11,7 +11,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
 
 inherit pypi python_hatchling
 
-SRC_URI[sha256sum] = "b5ecdd42262ca2462e2624793551e80911a1e989f462910bb81aef974b4bb383"
+SRC_URI[sha256sum] = "e9dbb5eada8abe4d9ae5f46b9939aead650cd2b68f249bb3a8139dbe125803cc"
 
 DEPENDS += "python3-hatch-fancy-pypi-readme-native"