diff mbox series

[meta-python,12/30] python3-mypy: upgrade 1.9.0 -> 1.10.0

Message ID 20240502144829.241208-12-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-networking,01/30] fping: upgrade 5.1 -> 5.2 | expand

Commit Message

Mingyu Wang (Fujitsu) May 2, 2024, 2:48 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
- Fix incorrect inferred type when accessing descriptor on union type
- Fix crash when expanding invalid Unpack in a Callable alias
- Fix false positive when string formatting with string enum
- Narrow individual items when matching a tuple to a sequence pattern
- Fix false positive from type variable within TypeGuard or TypeIs
- Improve yield from inference for unions of generators
- Fix emulating hash method logic in attrs classes
- Add reverted typeshed commit that uses ParamSpec for functools.wraps
- Fix type narrowing for types.EllipsisType
- Fix single item enum match type exhaustion
- Improve type inference with empty collections
- Fix override checking for decorated property
- Fix narrowing on match with function subject
- Allow +N within Literal[...]
- Experimental: Support TypedDict within type[...]
- Experimtental: Fix issue with TypedDict with optional keys in type[...]

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-mypy_1.9.0.bb => python3-mypy_1.10.0.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-mypy_1.9.0.bb => python3-mypy_1.10.0.bb} (86%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-mypy_1.9.0.bb b/meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-mypy_1.9.0.bb
rename to meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb
index e51264f8a..534ff9066 100644
--- a/meta-python/recipes-devtools/python/python3-mypy_1.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-mypy_1.10.0.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=8d62fd8f8648cb018e52857347e340b9"
 
 inherit pypi python_setuptools_build_meta
 
-SRC_URI[sha256sum] = "3cc5da0127e6a478cddd906068496a97a7618a21ce9b54bde5bf7e539c7af974"
+SRC_URI[sha256sum] = "3d087fcbec056c4ee34974da493a826ce316947485cef3901f511848e687c131"
 
 BBCLASSEXTEND = "native"