diff mbox series

[meta-oe,1/2] freerdp: Upgrade to 2.11.7

Message ID 20240509192537.1639358-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/2] freerdp: Upgrade to 2.11.7 | expand

Commit Message

Khem Raj May 9, 2024, 7:25 p.m. UTC
Partially backport a fix to build with gcc-14

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../0001-Fixed-compilation-warnings.patch     | 27 +++++++++++++++++++
 .../{freerdp_2.11.2.bb => freerdp_2.11.7.bb}  |  3 ++-
 2 files changed, 29 insertions(+), 1 deletion(-)
 create mode 100644 meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
 rename meta-oe/recipes-support/freerdp/{freerdp_2.11.2.bb => freerdp_2.11.7.bb} (97%)

Comments

Martin Jansa May 14, 2024, 6:39 a.m. UTC | #1
On Thu, May 9, 2024 at 9:25 PM Khem Raj via lists.openembedded.org
<raj.khem=gmail.com@lists.openembedded.org> wrote:
>
> Partially backport a fix to build with gcc-14

It fixes it only partially, right?

I'm stills seeing:

freerdp/2.11.7/git/libfreerdp/core/info.c:88:39: error: initialization
of 'const WCHAR *' {aka 'const short unsigned int *'} from
incompatible pointer type 'BYTE *' {aka 'unsigned char *'}
[-Wincompatible-pointer-types]
   88 |                 const WCHAR* domain = Stream_Pointer(s);
      |                                       ^~~~~~~~~~~~~~


> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  .../0001-Fixed-compilation-warnings.patch     | 27 +++++++++++++++++++
>  .../{freerdp_2.11.2.bb => freerdp_2.11.7.bb}  |  3 ++-
>  2 files changed, 29 insertions(+), 1 deletion(-)
>  create mode 100644 meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
>  rename meta-oe/recipes-support/freerdp/{freerdp_2.11.2.bb => freerdp_2.11.7.bb} (97%)
>
> diff --git a/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> new file mode 100644
> index 0000000000..7fae2703f8
> --- /dev/null
> +++ b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> @@ -0,0 +1,27 @@
> +From 75fa1fa5bd5ef2350390564245fd0984209ac092 Mon Sep 17 00:00:00 2001
> +From: akallabeth <akallabeth@posteo.net>
> +Date: Mon, 4 Jul 2022 14:34:46 +0200
> +Subject: [PATCH] Fixed compilation warnings
> +
> +Upstream-Status: Backport [https://github.com/FreeRDP/FreeRDP/commit/2da280b8a1748052b70b3f5a1ef0d8e932c33adc]
> +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> +---
> + client/X11/xf_graphics.c | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/client/X11/xf_graphics.c b/client/X11/xf_graphics.c
> +index 5aa1fd48b..fe81e0ed9 100644
> +--- a/client/X11/xf_graphics.c
> ++++ b/client/X11/xf_graphics.c
> +@@ -438,7 +438,7 @@ static BOOL xf_Pointer_New(rdpContext* context, rdpPointer* pointer)
> +
> + #endif
> + fail:
> +-      WLog_DBG(TAG, "%s: %ld", __func__, rc ? pointer : -1);
> ++      WLog_DBG(TAG, "%s: %p", __func__, rc ? pointer : NULL);
> +       return rc;
> + }
> +
> +--
> +2.45.0
> +
> diff --git a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> similarity index 97%
> rename from meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
> rename to meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> index 3319488051..43c38bf9c9 100644
> --- a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
> +++ b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> @@ -13,9 +13,10 @@ inherit pkgconfig cmake gitpkgv
>  PE = "1"
>  PKGV = "${GITPKGVTAG}"
>
> -SRCREV = "a38c1be9eee39a9bc22b511fffe96e63fdf8ebe7"
> +SRCREV = "7f6cc93c21d7f0faad6daacca06f494f29ce882c"
>  SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;branch=stable-2.0;protocol=https \
>             file://winpr-makecert-Build-with-install-RPATH.patch \
> +           file://0001-Fixed-compilation-warnings.patch \
>             file://0001-Fix-const-qualifier-error.patch \
>             file://0002-Do-not-install-tools-a-CMake-targets.patch \
>             "
> --
> 2.45.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#110294): https://lists.openembedded.org/g/openembedded-devel/message/110294
> Mute This Topic: https://lists.openembedded.org/mt/106007932/3617156
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [martin.jansa@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj May 14, 2024, 3:16 p.m. UTC | #2
On Mon, May 13, 2024 at 11:39 PM Martin Jansa <martin.jansa@gmail.com> wrote:
>
> On Thu, May 9, 2024 at 9:25 PM Khem Raj via lists.openembedded.org
> <raj.khem=gmail.com@lists.openembedded.org> wrote:
> >
> > Partially backport a fix to build with gcc-14
>
> It fixes it only partially, right?
>
> I'm stills seeing:
>
> freerdp/2.11.7/git/libfreerdp/core/info.c:88:39: error: initialization
> of 'const WCHAR *' {aka 'const short unsigned int *'} from
> incompatible pointer type 'BYTE *' {aka 'unsigned char *'}
> [-Wincompatible-pointer-types]
>    88 |                 const WCHAR* domain = Stream_Pointer(s);
>       |                                       ^~~~~~~~~~~~~~
>

Interesting, I did not encounter this, perhaps different machines maybe ?

>
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> >  .../0001-Fixed-compilation-warnings.patch     | 27 +++++++++++++++++++
> >  .../{freerdp_2.11.2.bb => freerdp_2.11.7.bb}  |  3 ++-
> >  2 files changed, 29 insertions(+), 1 deletion(-)
> >  create mode 100644 meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> >  rename meta-oe/recipes-support/freerdp/{freerdp_2.11.2.bb => freerdp_2.11.7.bb} (97%)
> >
> > diff --git a/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> > new file mode 100644
> > index 0000000000..7fae2703f8
> > --- /dev/null
> > +++ b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> > @@ -0,0 +1,27 @@
> > +From 75fa1fa5bd5ef2350390564245fd0984209ac092 Mon Sep 17 00:00:00 2001
> > +From: akallabeth <akallabeth@posteo.net>
> > +Date: Mon, 4 Jul 2022 14:34:46 +0200
> > +Subject: [PATCH] Fixed compilation warnings
> > +
> > +Upstream-Status: Backport [https://github.com/FreeRDP/FreeRDP/commit/2da280b8a1748052b70b3f5a1ef0d8e932c33adc]
> > +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > +---
> > + client/X11/xf_graphics.c | 2 +-
> > + 1 file changed, 1 insertion(+), 1 deletion(-)
> > +
> > +diff --git a/client/X11/xf_graphics.c b/client/X11/xf_graphics.c
> > +index 5aa1fd48b..fe81e0ed9 100644
> > +--- a/client/X11/xf_graphics.c
> > ++++ b/client/X11/xf_graphics.c
> > +@@ -438,7 +438,7 @@ static BOOL xf_Pointer_New(rdpContext* context, rdpPointer* pointer)
> > +
> > + #endif
> > + fail:
> > +-      WLog_DBG(TAG, "%s: %ld", __func__, rc ? pointer : -1);
> > ++      WLog_DBG(TAG, "%s: %p", __func__, rc ? pointer : NULL);
> > +       return rc;
> > + }
> > +
> > +--
> > +2.45.0
> > +
> > diff --git a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > similarity index 97%
> > rename from meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
> > rename to meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > index 3319488051..43c38bf9c9 100644
> > --- a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
> > +++ b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > @@ -13,9 +13,10 @@ inherit pkgconfig cmake gitpkgv
> >  PE = "1"
> >  PKGV = "${GITPKGVTAG}"
> >
> > -SRCREV = "a38c1be9eee39a9bc22b511fffe96e63fdf8ebe7"
> > +SRCREV = "7f6cc93c21d7f0faad6daacca06f494f29ce882c"
> >  SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;branch=stable-2.0;protocol=https \
> >             file://winpr-makecert-Build-with-install-RPATH.patch \
> > +           file://0001-Fixed-compilation-warnings.patch \
> >             file://0001-Fix-const-qualifier-error.patch \
> >             file://0002-Do-not-install-tools-a-CMake-targets.patch \
> >             "
> > --
> > 2.45.0
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#110294): https://lists.openembedded.org/g/openembedded-devel/message/110294
> > Mute This Topic: https://lists.openembedded.org/mt/106007932/3617156
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [martin.jansa@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Martin Jansa May 14, 2024, 3:24 p.m. UTC | #3
I've seen it with qemux86-64 and raspberrypi4-64 last night, both in
DISTRO without x11 in DISTRO_FEATURES.

freerdp3_3.5.1 doesn't seem to have this issue, version 2 was fixed last week:
https://github.com/FreeRDP/FreeRDP/commit/4f411197dc9d2076f00748b1178a60b2423030bf

will send a backport.

On Tue, May 14, 2024 at 5:17 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Mon, May 13, 2024 at 11:39 PM Martin Jansa <martin.jansa@gmail.com> wrote:
> >
> > On Thu, May 9, 2024 at 9:25 PM Khem Raj via lists.openembedded.org
> > <raj.khem=gmail.com@lists.openembedded.org> wrote:
> > >
> > > Partially backport a fix to build with gcc-14
> >
> > It fixes it only partially, right?
> >
> > I'm stills seeing:
> >
> > freerdp/2.11.7/git/libfreerdp/core/info.c:88:39: error: initialization
> > of 'const WCHAR *' {aka 'const short unsigned int *'} from
> > incompatible pointer type 'BYTE *' {aka 'unsigned char *'}
> > [-Wincompatible-pointer-types]
> >    88 |                 const WCHAR* domain = Stream_Pointer(s);
> >       |                                       ^~~~~~~~~~~~~~
> >
>
> Interesting, I did not encounter this, perhaps different machines maybe ?
>
> >
> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > ---
> > >  .../0001-Fixed-compilation-warnings.patch     | 27 +++++++++++++++++++
> > >  .../{freerdp_2.11.2.bb => freerdp_2.11.7.bb}  |  3 ++-
> > >  2 files changed, 29 insertions(+), 1 deletion(-)
> > >  create mode 100644 meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> > >  rename meta-oe/recipes-support/freerdp/{freerdp_2.11.2.bb => freerdp_2.11.7.bb} (97%)
> > >
> > > diff --git a/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> > > new file mode 100644
> > > index 0000000000..7fae2703f8
> > > --- /dev/null
> > > +++ b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> > > @@ -0,0 +1,27 @@
> > > +From 75fa1fa5bd5ef2350390564245fd0984209ac092 Mon Sep 17 00:00:00 2001
> > > +From: akallabeth <akallabeth@posteo.net>
> > > +Date: Mon, 4 Jul 2022 14:34:46 +0200
> > > +Subject: [PATCH] Fixed compilation warnings
> > > +
> > > +Upstream-Status: Backport [https://github.com/FreeRDP/FreeRDP/commit/2da280b8a1748052b70b3f5a1ef0d8e932c33adc]
> > > +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > +---
> > > + client/X11/xf_graphics.c | 2 +-
> > > + 1 file changed, 1 insertion(+), 1 deletion(-)
> > > +
> > > +diff --git a/client/X11/xf_graphics.c b/client/X11/xf_graphics.c
> > > +index 5aa1fd48b..fe81e0ed9 100644
> > > +--- a/client/X11/xf_graphics.c
> > > ++++ b/client/X11/xf_graphics.c
> > > +@@ -438,7 +438,7 @@ static BOOL xf_Pointer_New(rdpContext* context, rdpPointer* pointer)
> > > +
> > > + #endif
> > > + fail:
> > > +-      WLog_DBG(TAG, "%s: %ld", __func__, rc ? pointer : -1);
> > > ++      WLog_DBG(TAG, "%s: %p", __func__, rc ? pointer : NULL);
> > > +       return rc;
> > > + }
> > > +
> > > +--
> > > +2.45.0
> > > +
> > > diff --git a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > > similarity index 97%
> > > rename from meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
> > > rename to meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > > index 3319488051..43c38bf9c9 100644
> > > --- a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
> > > +++ b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > > @@ -13,9 +13,10 @@ inherit pkgconfig cmake gitpkgv
> > >  PE = "1"
> > >  PKGV = "${GITPKGVTAG}"
> > >
> > > -SRCREV = "a38c1be9eee39a9bc22b511fffe96e63fdf8ebe7"
> > > +SRCREV = "7f6cc93c21d7f0faad6daacca06f494f29ce882c"
> > >  SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;branch=stable-2.0;protocol=https \
> > >             file://winpr-makecert-Build-with-install-RPATH.patch \
> > > +           file://0001-Fixed-compilation-warnings.patch \
> > >             file://0001-Fix-const-qualifier-error.patch \
> > >             file://0002-Do-not-install-tools-a-CMake-targets.patch \
> > >             "
> > > --
> > > 2.45.0
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#110294): https://lists.openembedded.org/g/openembedded-devel/message/110294
> > > Mute This Topic: https://lists.openembedded.org/mt/106007932/3617156
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [martin.jansa@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
Khem Raj May 14, 2024, 3:38 p.m. UTC | #4
On Tue, May 14, 2024 at 8:24 AM Martin Jansa <martin.jansa@gmail.com> wrote:
>
> I've seen it with qemux86-64 and raspberrypi4-64 last night, both in
> DISTRO without x11 in DISTRO_FEATURES.
>
> freerdp3_3.5.1 doesn't seem to have this issue, version 2 was fixed last week:
> https://github.com/FreeRDP/FreeRDP/commit/4f411197dc9d2076f00748b1178a60b2423030bf
>
> will send a backport.
>

Superb, thanks for tracking it down.

> On Tue, May 14, 2024 at 5:17 PM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > On Mon, May 13, 2024 at 11:39 PM Martin Jansa <martin.jansa@gmail.com> wrote:
> > >
> > > On Thu, May 9, 2024 at 9:25 PM Khem Raj via lists.openembedded.org
> > > <raj.khem=gmail.com@lists.openembedded.org> wrote:
> > > >
> > > > Partially backport a fix to build with gcc-14
> > >
> > > It fixes it only partially, right?
> > >
> > > I'm stills seeing:
> > >
> > > freerdp/2.11.7/git/libfreerdp/core/info.c:88:39: error: initialization
> > > of 'const WCHAR *' {aka 'const short unsigned int *'} from
> > > incompatible pointer type 'BYTE *' {aka 'unsigned char *'}
> > > [-Wincompatible-pointer-types]
> > >    88 |                 const WCHAR* domain = Stream_Pointer(s);
> > >       |                                       ^~~~~~~~~~~~~~
> > >
> >
> > Interesting, I did not encounter this, perhaps different machines maybe ?
> >
> > >
> > > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > > ---
> > > >  .../0001-Fixed-compilation-warnings.patch     | 27 +++++++++++++++++++
> > > >  .../{freerdp_2.11.2.bb => freerdp_2.11.7.bb}  |  3 ++-
> > > >  2 files changed, 29 insertions(+), 1 deletion(-)
> > > >  create mode 100644 meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> > > >  rename meta-oe/recipes-support/freerdp/{freerdp_2.11.2.bb => freerdp_2.11.7.bb} (97%)
> > > >
> > > > diff --git a/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> > > > new file mode 100644
> > > > index 0000000000..7fae2703f8
> > > > --- /dev/null
> > > > +++ b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
> > > > @@ -0,0 +1,27 @@
> > > > +From 75fa1fa5bd5ef2350390564245fd0984209ac092 Mon Sep 17 00:00:00 2001
> > > > +From: akallabeth <akallabeth@posteo.net>
> > > > +Date: Mon, 4 Jul 2022 14:34:46 +0200
> > > > +Subject: [PATCH] Fixed compilation warnings
> > > > +
> > > > +Upstream-Status: Backport [https://github.com/FreeRDP/FreeRDP/commit/2da280b8a1748052b70b3f5a1ef0d8e932c33adc]
> > > > +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > > +---
> > > > + client/X11/xf_graphics.c | 2 +-
> > > > + 1 file changed, 1 insertion(+), 1 deletion(-)
> > > > +
> > > > +diff --git a/client/X11/xf_graphics.c b/client/X11/xf_graphics.c
> > > > +index 5aa1fd48b..fe81e0ed9 100644
> > > > +--- a/client/X11/xf_graphics.c
> > > > ++++ b/client/X11/xf_graphics.c
> > > > +@@ -438,7 +438,7 @@ static BOOL xf_Pointer_New(rdpContext* context, rdpPointer* pointer)
> > > > +
> > > > + #endif
> > > > + fail:
> > > > +-      WLog_DBG(TAG, "%s: %ld", __func__, rc ? pointer : -1);
> > > > ++      WLog_DBG(TAG, "%s: %p", __func__, rc ? pointer : NULL);
> > > > +       return rc;
> > > > + }
> > > > +
> > > > +--
> > > > +2.45.0
> > > > +
> > > > diff --git a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > > > similarity index 97%
> > > > rename from meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
> > > > rename to meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > > > index 3319488051..43c38bf9c9 100644
> > > > --- a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
> > > > +++ b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
> > > > @@ -13,9 +13,10 @@ inherit pkgconfig cmake gitpkgv
> > > >  PE = "1"
> > > >  PKGV = "${GITPKGVTAG}"
> > > >
> > > > -SRCREV = "a38c1be9eee39a9bc22b511fffe96e63fdf8ebe7"
> > > > +SRCREV = "7f6cc93c21d7f0faad6daacca06f494f29ce882c"
> > > >  SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;branch=stable-2.0;protocol=https \
> > > >             file://winpr-makecert-Build-with-install-RPATH.patch \
> > > > +           file://0001-Fixed-compilation-warnings.patch \
> > > >             file://0001-Fix-const-qualifier-error.patch \
> > > >             file://0002-Do-not-install-tools-a-CMake-targets.patch \
> > > >             "
> > > > --
> > > > 2.45.0
> > > >
> > > >
> > > > -=-=-=-=-=-=-=-=-=-=-=-
> > > > Links: You receive all messages sent to this group.
> > > > View/Reply Online (#110294): https://lists.openembedded.org/g/openembedded-devel/message/110294
> > > > Mute This Topic: https://lists.openembedded.org/mt/106007932/3617156
> > > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [martin.jansa@gmail.com]
> > > > -=-=-=-=-=-=-=-=-=-=-=-
> > > >
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
new file mode 100644
index 0000000000..7fae2703f8
--- /dev/null
+++ b/meta-oe/recipes-support/freerdp/freerdp/0001-Fixed-compilation-warnings.patch
@@ -0,0 +1,27 @@ 
+From 75fa1fa5bd5ef2350390564245fd0984209ac092 Mon Sep 17 00:00:00 2001
+From: akallabeth <akallabeth@posteo.net>
+Date: Mon, 4 Jul 2022 14:34:46 +0200
+Subject: [PATCH] Fixed compilation warnings
+
+Upstream-Status: Backport [https://github.com/FreeRDP/FreeRDP/commit/2da280b8a1748052b70b3f5a1ef0d8e932c33adc]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ client/X11/xf_graphics.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/client/X11/xf_graphics.c b/client/X11/xf_graphics.c
+index 5aa1fd48b..fe81e0ed9 100644
+--- a/client/X11/xf_graphics.c
++++ b/client/X11/xf_graphics.c
+@@ -438,7 +438,7 @@ static BOOL xf_Pointer_New(rdpContext* context, rdpPointer* pointer)
+ 
+ #endif
+ fail:
+-	WLog_DBG(TAG, "%s: %ld", __func__, rc ? pointer : -1);
++	WLog_DBG(TAG, "%s: %p", __func__, rc ? pointer : NULL);
+ 	return rc;
+ }
+ 
+-- 
+2.45.0
+
diff --git a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
similarity index 97%
rename from meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
rename to meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
index 3319488051..43c38bf9c9 100644
--- a/meta-oe/recipes-support/freerdp/freerdp_2.11.2.bb
+++ b/meta-oe/recipes-support/freerdp/freerdp_2.11.7.bb
@@ -13,9 +13,10 @@  inherit pkgconfig cmake gitpkgv
 PE = "1"
 PKGV = "${GITPKGVTAG}"
 
-SRCREV = "a38c1be9eee39a9bc22b511fffe96e63fdf8ebe7"
+SRCREV = "7f6cc93c21d7f0faad6daacca06f494f29ce882c"
 SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;branch=stable-2.0;protocol=https \
            file://winpr-makecert-Build-with-install-RPATH.patch \
+           file://0001-Fixed-compilation-warnings.patch \
            file://0001-Fix-const-qualifier-error.patch \
            file://0002-Do-not-install-tools-a-CMake-targets.patch \
            "