diff mbox series

[meta-oe] composefs: add a new recipe

Message ID 20240405162459.1286945-1-fathi.boudra@linaro.org
State Accepted
Headers show
Series [meta-oe] composefs: add a new recipe | expand

Commit Message

Fathi Boudra April 5, 2024, 4:24 p.m. UTC
Tools to handle creating and mounting composefs images

Flexible mechanism to support read-only mountable filesystem trees,
stacking on top of Linux filesystem.

It will allow to enable filesystem integrity by leveraging the stack:
ostree -> composefs -> fs-verity

For reference:
https://github.com/containers/composefs?tab=readme-ov-file#filesystem-integrity
https://ostreedev.github.io/ostree/composefs/#using-composefs-with-ostree

Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
---
 .../composefs/composefs_1.0.3.bb              | 20 +++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta-oe/recipes-extended/composefs/composefs_1.0.3.bb

Comments

Khem Raj April 6, 2024, 1:03 a.m. UTC | #1
fails with latest musl

https://errors.yoctoproject.org/Errors/Details/761688/

On Fri, Apr 5, 2024 at 9:25 AM Fathi Boudra <fathi.boudra@linaro.org> wrote:
>
> Tools to handle creating and mounting composefs images
>
> Flexible mechanism to support read-only mountable filesystem trees,
> stacking on top of Linux filesystem.
>
> It will allow to enable filesystem integrity by leveraging the stack:
> ostree -> composefs -> fs-verity
>
> For reference:
> https://github.com/containers/composefs?tab=readme-ov-file#filesystem-integrity
> https://ostreedev.github.io/ostree/composefs/#using-composefs-with-ostree
>
> Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
> ---
>  .../composefs/composefs_1.0.3.bb              | 20 +++++++++++++++++++
>  1 file changed, 20 insertions(+)
>  create mode 100644 meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
>
> diff --git a/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb b/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
> new file mode 100644
> index 0000000000..ddc67d9b57
> --- /dev/null
> +++ b/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
> @@ -0,0 +1,20 @@
> +SUMMARY = "Tools to handle creating and mounting composefs images"
> +HOMEPAGE = "https://github.com/containers/composefs"
> +LICENSE = "GPL-3.0-or-later & LGPL-2.0-or-later & Apache-2.0"
> +LIC_FILES_CHKSUM = "\
> +    file://BSD-2-Clause.txt;md5=121c8a0a8fa5961a26b7863034ebcce8 \
> +    file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> +    file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
> +    file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
> +    file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \
> +    file://LICENSE.Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \
> +"
> +DEPENDS = "fuse3 openssl"
> +SRCREV = "2d5cdcb9176cfe4ccf1761ef6d78e1c48de35649"
> +PV = "1.0.3"
> +
> +SRC_URI = "git://github.com/containers/composefs.git;protocol=https;branch=main"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit autotools pkgconfig
> --
> 2.43.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109825): https://lists.openembedded.org/g/openembedded-devel/message/109825
> Mute This Topic: https://lists.openembedded.org/mt/105351850/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj April 6, 2024, 5:03 p.m. UTC | #2
also fails

stdio: ERROR: Nothing PROVIDES 'fuse3' (but
/home/pokybuild/yocto-worker/meta-oe/build/meta-openembedded/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
DEPENDS on or otherwise requires it)

this is because fuse3 is in meta-filesystem and meta-oe does not depend on it.

On Fri, Apr 5, 2024 at 6:03 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> fails with latest musl
>
> https://errors.yoctoproject.org/Errors/Details/761688/
>
> On Fri, Apr 5, 2024 at 9:25 AM Fathi Boudra <fathi.boudra@linaro.org> wrote:
> >
> > Tools to handle creating and mounting composefs images
> >
> > Flexible mechanism to support read-only mountable filesystem trees,
> > stacking on top of Linux filesystem.
> >
> > It will allow to enable filesystem integrity by leveraging the stack:
> > ostree -> composefs -> fs-verity
> >
> > For reference:
> > https://github.com/containers/composefs?tab=readme-ov-file#filesystem-integrity
> > https://ostreedev.github.io/ostree/composefs/#using-composefs-with-ostree
> >
> > Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
> > ---
> >  .../composefs/composefs_1.0.3.bb              | 20 +++++++++++++++++++
> >  1 file changed, 20 insertions(+)
> >  create mode 100644 meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
> >
> > diff --git a/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb b/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
> > new file mode 100644
> > index 0000000000..ddc67d9b57
> > --- /dev/null
> > +++ b/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
> > @@ -0,0 +1,20 @@
> > +SUMMARY = "Tools to handle creating and mounting composefs images"
> > +HOMEPAGE = "https://github.com/containers/composefs"
> > +LICENSE = "GPL-3.0-or-later & LGPL-2.0-or-later & Apache-2.0"
> > +LIC_FILES_CHKSUM = "\
> > +    file://BSD-2-Clause.txt;md5=121c8a0a8fa5961a26b7863034ebcce8 \
> > +    file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> > +    file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
> > +    file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
> > +    file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \
> > +    file://LICENSE.Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \
> > +"
> > +DEPENDS = "fuse3 openssl"
> > +SRCREV = "2d5cdcb9176cfe4ccf1761ef6d78e1c48de35649"
> > +PV = "1.0.3"
> > +
> > +SRC_URI = "git://github.com/containers/composefs.git;protocol=https;branch=main"
> > +
> > +S = "${WORKDIR}/git"
> > +
> > +inherit autotools pkgconfig
> > --
> > 2.43.0
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#109825): https://lists.openembedded.org/g/openembedded-devel/message/109825
> > Mute This Topic: https://lists.openembedded.org/mt/105351850/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Fathi Boudra April 8, 2024, 1:50 p.m. UTC | #3
Hi Khem,

On Sat, 6 Apr 2024 at 03:04, Khem Raj <raj.khem@gmail.com> wrote:
>
> fails with latest musl
>
> https://errors.yoctoproject.org/Errors/Details/761688/

I tried to reproduce:

local.conf:
MACHINE = "qemuarm64"
TCLIBC = "musl"
TOOLCHAIN = "clang"

$ bitbake -e musl |grep "^PV="
PV="1.2.4+git"

Build Configuration:
BB_VERSION           = "2.7.3"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "debian"
TARGET_SYS           = "aarch64-oe-linux-musl"
MACHINE              = "qemuarm64"
DISTRO               = "nodistro"
DISTRO_VERSION       = "nodistro.0"
TUNE_FEATURES        = "aarch64 crc cortexa57"
TARGET_FPU           = ""
meta                 = "master:486ed69939f1b7572f121960c2dde246032686e7"
meta-clang           = "master:13dcab852c5bcd51fd75ae84ace9eddd99254653"
meta-filesystems
meta-networking
meta-oe
meta-python          = "master:5a02b76b82d1f48986212c33dddf7986385c79ef"

I couldn't reproduce the build failure. What am I missing?

> On Fri, Apr 5, 2024 at 9:25 AM Fathi Boudra <fathi.boudra@linaro.org> wrote:
> >
> > Tools to handle creating and mounting composefs images
> >
> > Flexible mechanism to support read-only mountable filesystem trees,
> > stacking on top of Linux filesystem.
> >
> > It will allow to enable filesystem integrity by leveraging the stack:
> > ostree -> composefs -> fs-verity
> >
> > For reference:
> > https://github.com/containers/composefs?tab=readme-ov-file#filesystem-integrity
> > https://ostreedev.github.io/ostree/composefs/#using-composefs-with-ostree
> >
> > Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
> > ---
> >  .../composefs/composefs_1.0.3.bb              | 20 +++++++++++++++++++
> >  1 file changed, 20 insertions(+)
> >  create mode 100644 meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
> >
> > diff --git a/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb b/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
> > new file mode 100644
> > index 0000000000..ddc67d9b57
> > --- /dev/null
> > +++ b/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
> > @@ -0,0 +1,20 @@
> > +SUMMARY = "Tools to handle creating and mounting composefs images"
> > +HOMEPAGE = "https://github.com/containers/composefs"
> > +LICENSE = "GPL-3.0-or-later & LGPL-2.0-or-later & Apache-2.0"
> > +LIC_FILES_CHKSUM = "\
> > +    file://BSD-2-Clause.txt;md5=121c8a0a8fa5961a26b7863034ebcce8 \
> > +    file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> > +    file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
> > +    file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
> > +    file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \
> > +    file://LICENSE.Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \
> > +"
> > +DEPENDS = "fuse3 openssl"
> > +SRCREV = "2d5cdcb9176cfe4ccf1761ef6d78e1c48de35649"
> > +PV = "1.0.3"
> > +
> > +SRC_URI = "git://github.com/containers/composefs.git;protocol=https;branch=main"
> > +
> > +S = "${WORKDIR}/git"
> > +
> > +inherit autotools pkgconfig
> > --
> > 2.43.0
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#109825): https://lists.openembedded.org/g/openembedded-devel/message/109825
> > Mute This Topic: https://lists.openembedded.org/mt/105351850/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >

Cheers,
Martin Jansa April 8, 2024, 2:17 p.m. UTC | #4
On Mon, Apr 8, 2024 at 3:50 PM Fathi Boudra <fathi.boudra@linaro.org> wrote:
>
> Hi Khem,
>
> On Sat, 6 Apr 2024 at 03:04, Khem Raj <raj.khem@gmail.com> wrote:
> >
> > fails with latest musl
> >
> > https://errors.yoctoproject.org/Errors/Details/761688/
>
> I tried to reproduce:
>
> local.conf:
> MACHINE = "qemuarm64"
> TCLIBC = "musl"
> TOOLCHAIN = "clang"
>
> $ bitbake -e musl |grep "^PV="
> PV="1.2.4+git"
>
> Build Configuration:
> BB_VERSION           = "2.7.3"
> BUILD_SYS            = "x86_64-linux"
> NATIVELSBSTRING      = "debian"
> TARGET_SYS           = "aarch64-oe-linux-musl"
> MACHINE              = "qemuarm64"
> DISTRO               = "nodistro"
> DISTRO_VERSION       = "nodistro.0"
> TUNE_FEATURES        = "aarch64 crc cortexa57"
> TARGET_FPU           = ""
> meta                 = "master:486ed69939f1b7572f121960c2dde246032686e7"
> meta-clang           = "master:13dcab852c5bcd51fd75ae84ace9eddd99254653"
> meta-filesystems
> meta-networking
> meta-oe
> meta-python          = "master:5a02b76b82d1f48986212c33dddf7986385c79ef"
>
> I couldn't reproduce the build failure. What am I missing?

removing meta-filesystems from your bblayers.conf
Fathi Boudra April 8, 2024, 2:32 p.m. UTC | #5
Hi Martin,

On Mon, 8 Apr 2024 at 16:18, Martin Jansa <martin.jansa@gmail.com> wrote:
>
> On Mon, Apr 8, 2024 at 3:50 PM Fathi Boudra <fathi.boudra@linaro.org> wrote:
> >
> > Hi Khem,
> >
> > On Sat, 6 Apr 2024 at 03:04, Khem Raj <raj.khem@gmail.com> wrote:
> > >
> > > fails with latest musl
> > >
> > > https://errors.yoctoproject.org/Errors/Details/761688/
> >
> > I tried to reproduce:
> >
> > local.conf:
> > MACHINE = "qemuarm64"
> > TCLIBC = "musl"
> > TOOLCHAIN = "clang"
> >
> > $ bitbake -e musl |grep "^PV="
> > PV="1.2.4+git"
> >
> > Build Configuration:
> > BB_VERSION           = "2.7.3"
> > BUILD_SYS            = "x86_64-linux"
> > NATIVELSBSTRING      = "debian"
> > TARGET_SYS           = "aarch64-oe-linux-musl"
> > MACHINE              = "qemuarm64"
> > DISTRO               = "nodistro"
> > DISTRO_VERSION       = "nodistro.0"
> > TUNE_FEATURES        = "aarch64 crc cortexa57"
> > TARGET_FPU           = ""
> > meta                 = "master:486ed69939f1b7572f121960c2dde246032686e7"
> > meta-clang           = "master:13dcab852c5bcd51fd75ae84ace9eddd99254653"
> > meta-filesystems
> > meta-networking
> > meta-oe
> > meta-python          = "master:5a02b76b82d1f48986212c33dddf7986385c79ef"
> >
> > I couldn't reproduce the build failure. What am I missing?
>
> removing meta-filesystems from your bblayers.conf

no, I'm asking about the musl basename() related build failure.

The build failure about fuse3 dependency is quite obvious.
In my local build, I moved the recipe to
meta-filesystems/recipes-support/composefs/
I'll submit a v2 for the latter but if I can reproduce the musl issue
and get it fixed for v2 that would be great.
Martin Jansa April 8, 2024, 2:40 p.m. UTC | #6
> > >
> > > I couldn't reproduce the build failure. What am I missing?
> >
> > removing meta-filesystems from your bblayers.conf
>
> no, I'm asking about the musl basename() related build failure.
>
> The build failure about fuse3 dependency is quite obvious.
> In my local build, I moved the recipe to
> meta-filesystems/recipes-support/composefs/
> I'll submit a v2 for the latter but if I can reproduce the musl issue
> and get it fixed for v2 that would be great.

Hi Fathi,

I'm sorry, I've realized it just after sending the reply, gmail was
showing your mail as a reply to the one about meta-filesystem and I
didn't notice the musl issue before sending the reply, will fix that
with another (6th) coffee :).

Cheers,
Jose Quaresma April 8, 2024, 2:56 p.m. UTC | #7
Hi Fathi,

To reproduce the musl issue maybe you need to use the yoe/mut branch.

https://git.yoctoproject.org/poky-contrib/log/?h=yoe/mut

Jose


Martin Jansa <martin.jansa@gmail.com> escreveu (segunda, 8/04/2024 à(s)
15:40):

> > > >
> > > > I couldn't reproduce the build failure. What am I missing?
> > >
> > > removing meta-filesystems from your bblayers.conf
> >
> > no, I'm asking about the musl basename() related build failure.
> >
> > The build failure about fuse3 dependency is quite obvious.
> > In my local build, I moved the recipe to
> > meta-filesystems/recipes-support/composefs/
> > I'll submit a v2 for the latter but if I can reproduce the musl issue
> > and get it fixed for v2 that would be great.
>
> Hi Fathi,
>
> I'm sorry, I've realized it just after sending the reply, gmail was
> showing your mail as a reply to the one about meta-filesystem and I
> didn't notice the musl issue before sending the reply, will fix that
> with another (6th) coffee :).
>
> Cheers,
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109867):
> https://lists.openembedded.org/g/openembedded-devel/message/109867
> Mute This Topic: https://lists.openembedded.org/mt/105351850/5052612
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> quaresma.jose@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Fathi Boudra April 8, 2024, 4:57 p.m. UTC | #8
Thanks José for the pointer!

I'm retrying to reproduce with yoe/mut. Build is in progress:

Build Configuration:
BB_VERSION           = "2.7.3"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "debian"
TARGET_SYS           = "aarch64-yoe-linux-musl"
MACHINE              = "qemuarm64"
DISTRO               = "yoe"
DISTRO_VERSION       = "2024.04-rc.1"
TUNE_FEATURES        = "aarch64 crc cortexa57"
TARGET_FPU           = ""
meta-yoe             = "yoe/mut:3a9ae512457c59118b66f57a0db0b09cee6bd757"
meta-clang           = "HEAD:13dcab852c5bcd51fd75ae84ace9eddd99254653"
meta-qt6             = "HEAD:0de8ffa779c1400795f8ff3a768c2dd9fa41b579"
meta-filesystems
meta-gnome
meta-initramfs
meta-multimedia
meta-networking
meta-oe
meta-perl
meta-python
meta-webserver
meta-xfce            = "HEAD:9b51108d77419943c967ed1bebd734acc827568d"
meta                 = "HEAD:e602713fe6987d0512d368409946fee56c67caf7"


On Mon, 8 Apr 2024 at 16:56, Jose Quaresma <quaresma.jose@gmail.com> wrote:
>
> Hi Fathi,
>
> To reproduce the musl issue maybe you need to use the yoe/mut branch.
>
> https://git.yoctoproject.org/poky-contrib/log/?h=yoe/mut
>
> Jose
>
>
> Martin Jansa <martin.jansa@gmail.com> escreveu (segunda, 8/04/2024 à(s) 15:40):
>>
>> > > >
>> > > > I couldn't reproduce the build failure. What am I missing?
>> > >
>> > > removing meta-filesystems from your bblayers.conf
>> >
>> > no, I'm asking about the musl basename() related build failure.
>> >
>> > The build failure about fuse3 dependency is quite obvious.
>> > In my local build, I moved the recipe to
>> > meta-filesystems/recipes-support/composefs/
>> > I'll submit a v2 for the latter but if I can reproduce the musl issue
>> > and get it fixed for v2 that would be great.
>>
>> Hi Fathi,
>>
>> I'm sorry, I've realized it just after sending the reply, gmail was
>> showing your mail as a reply to the one about meta-filesystem and I
>> didn't notice the musl issue before sending the reply, will fix that
>> with another (6th) coffee :).
>>
>> Cheers,
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#109867): https://lists.openembedded.org/g/openembedded-devel/message/109867
>> Mute This Topic: https://lists.openembedded.org/mt/105351850/5052612
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [quaresma.jose@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>
>
> --
> Best regards,
>
> José Quaresma
Jose Quaresma May 9, 2024, 6:32 a.m. UTC | #9
Hi Fathi,

I am thinking of moving this back again to the meta-oe/recipes-extended/com
posefs.
The fuse3 is only used for development purposes and the composefs uses the
kernel overlayfs and erofs on the target.
So in my opinion we can remove inteirly the fuse support in OE.

I'm also adding support for the native target that will be required for the
next ostree v2024.6

Jose

Fathi Boudra <fathi.boudra@linaro.org> escreveu (segunda, 8/04/2024 à(s)
15:33):

> Hi Martin,
>
> On Mon, 8 Apr 2024 at 16:18, Martin Jansa <martin.jansa@gmail.com> wrote:
> >
> > On Mon, Apr 8, 2024 at 3:50 PM Fathi Boudra <fathi.boudra@linaro.org>
> wrote:
> > >
> > > Hi Khem,
> > >
> > > On Sat, 6 Apr 2024 at 03:04, Khem Raj <raj.khem@gmail.com> wrote:
> > > >
> > > > fails with latest musl
> > > >
> > > > https://errors.yoctoproject.org/Errors/Details/761688/
> > >
> > > I tried to reproduce:
> > >
> > > local.conf:
> > > MACHINE = "qemuarm64"
> > > TCLIBC = "musl"
> > > TOOLCHAIN = "clang"
> > >
> > > $ bitbake -e musl |grep "^PV="
> > > PV="1.2.4+git"
> > >
> > > Build Configuration:
> > > BB_VERSION           = "2.7.3"
> > > BUILD_SYS            = "x86_64-linux"
> > > NATIVELSBSTRING      = "debian"
> > > TARGET_SYS           = "aarch64-oe-linux-musl"
> > > MACHINE              = "qemuarm64"
> > > DISTRO               = "nodistro"
> > > DISTRO_VERSION       = "nodistro.0"
> > > TUNE_FEATURES        = "aarch64 crc cortexa57"
> > > TARGET_FPU           = ""
> > > meta                 =
> "master:486ed69939f1b7572f121960c2dde246032686e7"
> > > meta-clang           =
> "master:13dcab852c5bcd51fd75ae84ace9eddd99254653"
> > > meta-filesystems
> > > meta-networking
> > > meta-oe
> > > meta-python          =
> "master:5a02b76b82d1f48986212c33dddf7986385c79ef"
> > >
> > > I couldn't reproduce the build failure. What am I missing?
> >
> > removing meta-filesystems from your bblayers.conf
>
> no, I'm asking about the musl basename() related build failure.
>
> The build failure about fuse3 dependency is quite obvious.
> In my local build, I moved the recipe to
> meta-filesystems/recipes-support/composefs/
> I'll submit a v2 for the latter but if I can reproduce the musl issue
> and get it fixed for v2 that would be great.
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109866):
> https://lists.openembedded.org/g/openembedded-devel/message/109866
> Mute This Topic: https://lists.openembedded.org/mt/105351850/5052612
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> quaresma.jose@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb b/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
new file mode 100644
index 0000000000..ddc67d9b57
--- /dev/null
+++ b/meta-oe/recipes-extended/composefs/composefs_1.0.3.bb
@@ -0,0 +1,20 @@ 
+SUMMARY = "Tools to handle creating and mounting composefs images"
+HOMEPAGE = "https://github.com/containers/composefs"
+LICENSE = "GPL-3.0-or-later & LGPL-2.0-or-later & Apache-2.0"
+LIC_FILES_CHKSUM = "\
+    file://BSD-2-Clause.txt;md5=121c8a0a8fa5961a26b7863034ebcce8 \
+    file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+    file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
+    file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+    file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \
+    file://LICENSE.Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+"
+DEPENDS = "fuse3 openssl"
+SRCREV = "2d5cdcb9176cfe4ccf1761ef6d78e1c48de35649"
+PV = "1.0.3"
+
+SRC_URI = "git://github.com/containers/composefs.git;protocol=https;branch=main"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig