diff mbox series

[meta-gnome] gnome-user-share: add recipe

Message ID 20240327160808.22384-1-f_l_k@t-online.de
State Accepted
Headers show
Series [meta-gnome] gnome-user-share: add recipe | expand

Commit Message

Markus Volk March 27, 2024, 4:08 p.m. UTC
- add it as runtime dependency to gnome-control-center because without it,
  the file sharing options are hidden.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../gnome-control-center_46.0.bb              |  2 +-
 .../gnome-user-share/gnome-user-share_43.0.bb | 23 +++++++++++++++++++
 2 files changed, 24 insertions(+), 1 deletion(-)
 create mode 100644 meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb

Comments

Khem Raj March 27, 2024, 6:21 p.m. UTC | #1
this does not work properly with non-systemd distros

09:44:18 ERROR: Nothing PROVIDES 'systemd' (but
/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
DEPENDS on or otherwise requires it)
09:44:18 systemd was skipped: missing required distro feature
'systemd' (not in DISTRO_FEATURES)
09:44:24 ERROR: Nothing RPROVIDES 'gnome-user-share-dev' (but
/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
RDEPENDS on or otherwise requires it)
09:44:24 No eligible RPROVIDERs exist for 'gnome-user-share-dev'
09:44:24 NOTE: Runtime target 'gnome-user-share-dev' is unbuildable, removing...
09:44:24 Missing or unbuildable dependency chain was: ['gnome-user-share-dev']
09:44:29 ERROR: Nothing RPROVIDES 'gnome-user-share' (but
/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
RDEPENDS on or otherwise requires it)
09:44:29 No eligible RPROVIDERs exist for 'gnome-user-share'
09:44:29 NOTE: Runtime target 'gnome-user-share' is unbuildable, removing...
09:44:29 Missing or unbuildable dependency chain was: ['gnome-user-share']

On Wed, Mar 27, 2024 at 9:07 AM Markus Volk <f_l_k@t-online.de> wrote:
>
> - add it as runtime dependency to gnome-control-center because without it,
>   the file sharing options are hidden.
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  .../gnome-control-center_46.0.bb              |  2 +-
>  .../gnome-user-share/gnome-user-share_43.0.bb | 23 +++++++++++++++++++
>  2 files changed, 24 insertions(+), 1 deletion(-)
>  create mode 100644 meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
>
> diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
> index a691b8d3f..4acb96967 100644
> --- a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
> +++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
> @@ -69,4 +69,4 @@ FILES:${PN} += " \
>
>  FILES:${PN}-dev += "${datadir}/gettext"
>
> -RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper"
> +RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper gnome-user-share"
> diff --git a/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb b/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
> new file mode 100644
> index 000000000..450ea6cfa
> --- /dev/null
> +++ b/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
> @@ -0,0 +1,23 @@
> +SUMMARY = "This is gnome-user-share 43.0, a system for easy sharing of user files."
> +LICENSE="GPL-2.0-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
> +
> +
> +DEPENDS = " \
> +    glib-2.0-native \
> +    glib-2.0 \
> +    systemd \
> +"
> +
> +inherit gnomebase gsettings
> +
> +SRC_URI = "git://gitlab.gnome.org/GNOME/gnome-user-share.git;protocol=https;branch=master"
> +SRCREV = "a0e790aa9494db9d1b1f48b4fc0d2f78e112044d"
> +S = "${WORKDIR}/git"
> +
> +PACKAGECONFIG ??= ""
> +# default path is /usr/sbin/httpd
> +PACKAGECONFIG[httpd2] = "-Dhttps=httpd,,,apache2"
> +PACKAGECONFIG[apache2] = "-Dhttps=apache2,,,apache2"
> +
> +FILES:${PN} += "${systemd_user_unitdir}"
> --
> 2.44.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109646): https://lists.openembedded.org/g/openembedded-devel/message/109646
> Mute This Topic: https://lists.openembedded.org/mt/105180141/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Markus Volk March 28, 2024, 7:44 a.m. UTC | #2
On Wed, Mar 27 2024 at 11:21:56 AM -07:00:00, Khem Raj 
<raj.khem@gmail.com> wrote:
> this does not work properly with non-systemd distros

Right, and systemd is not optional.Will send a patch for it
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
index a691b8d3f..4acb96967 100644
--- a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
@@ -69,4 +69,4 @@  FILES:${PN} += " \
 
 FILES:${PN}-dev += "${datadir}/gettext"
 
-RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper"
+RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper gnome-user-share"
diff --git a/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb b/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
new file mode 100644
index 000000000..450ea6cfa
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "This is gnome-user-share 43.0, a system for easy sharing of user files."
+LICENSE="GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+
+DEPENDS = " \
+    glib-2.0-native \
+    glib-2.0 \
+    systemd \
+"
+
+inherit gnomebase gsettings
+
+SRC_URI = "git://gitlab.gnome.org/GNOME/gnome-user-share.git;protocol=https;branch=master"
+SRCREV = "a0e790aa9494db9d1b1f48b4fc0d2f78e112044d"
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG ??= ""
+# default path is /usr/sbin/httpd
+PACKAGECONFIG[httpd2] = "-Dhttps=httpd,,,apache2"
+PACKAGECONFIG[apache2] = "-Dhttps=apache2,,,apache2"
+
+FILES:${PN} += "${systemd_user_unitdir}"