diff mbox series

[meta-networking,3/4] openflow: Fix build with musl

Message ID 20240324031006.3072120-3-raj.khem@gmail.com
State New
Headers show
Series [meta-networking,1/4] openflow: Delete recipe for 1.0 | expand

Commit Message

Khem Raj March 24, 2024, 3:10 a.m. UTC
Link in external library to provide backtrace functions
since they are not part of C library

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-networking/recipes-protocols/openflow/openflow_git.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-networking/recipes-protocols/openflow/openflow_git.bb b/meta-networking/recipes-protocols/openflow/openflow_git.bb
index eadfc25461..41bedcd0cf 100644
--- a/meta-networking/recipes-protocols/openflow/openflow_git.bb
+++ b/meta-networking/recipes-protocols/openflow/openflow_git.bb
@@ -35,6 +35,9 @@  EXTRA_OECONF += " \
                  ${@bb.utils.contains('PACKAGECONFIG', 'openssl', 'SSL_LIBS="-lssl -lcrypto"', '', d)} \
                 "
 
+DEPENDS:append:libc-musl = " libexecinfo"
+LDFLAGS:append:libc-musl = " -lexecinfo"
+
 S = "${WORKDIR}/git"
 
 inherit autotools-brokensep pkgconfig