diff mbox series

[meta-multimedia,v2] gstd: Fix systemd user unit packaging

Message ID 20231201165727.8679-1-raj.khem@gmail.com
State New
Headers show
Series [meta-multimedia,v2] gstd: Fix systemd user unit packaging | expand

Commit Message

Khem Raj Dec. 1, 2023, 4:57 p.m. UTC
We do not need to preprocess it offline as its not run per session but
per user.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Mark Hatle <mark.hatle@amd.com>
---
v2: Fix runtime systemd service launch issue

 .../recipes-multimedia/gstreamer-1.0/gstd_git.bb            | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

Comments

Mark Hatle Dec. 1, 2023, 7:01 p.m. UTC | #1
After talking with Khem (and running this) I think this is the right solution.

Thanks!
--Mark

On 12/1/23 10:57 AM, Khem Raj wrote:
> We do not need to preprocess it offline as its not run per session but
> per user.
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Mark Hatle <mark.hatle@amd.com>
> ---
> v2: Fix runtime systemd service launch issue
> 
>   .../recipes-multimedia/gstreamer-1.0/gstd_git.bb            | 6 ++----
>   1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
> index 88acdb190e..cabbf2cc11 100644
> --- a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
> +++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
> @@ -17,7 +17,7 @@ PV = "1.0+really0.15.0"
>   
>   GTKDOC_MESON_OPTION = "enable-gtk-doc"
>   
> -inherit meson pkgconfig gettext gtk-doc systemd python3native python3-dir python3targetconfig
> +inherit meson pkgconfig gettext gtk-doc python3native python3-dir python3targetconfig
>   
>   do_install:append() {
>           rmdir ${D}${root_prefix}${localstatedir}/run/${BPN} ${D}${root_prefix}${localstatedir}/run \
> @@ -28,7 +28,7 @@ do_install:append() {
>                   install -d ${D}${sysconfdir}/tmpfiles.d
>                   echo "d /run/${BPN} - - - -" \
>                   > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
> -                echo "d /${localstatedir}/log/${BPN} 0755 root root -" \
> +                echo "d ${localstatedir}/log/${BPN} 0755 root root -" \
>                   >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
>           fi
>           ln -sf gst-client-1.0 ${D}${bindir}/gst-client
> @@ -38,5 +38,3 @@ PACKAGES =+ "${PN}-python"
>   
>   FILES:${PN} += "${systemd_user_unitdir}"
>   FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
> -
> -SYSTEMD_SERVICE:${PN} = "gstd.service"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107191): https://lists.openembedded.org/g/openembedded-devel/message/107191
> Mute This Topic: https://lists.openembedded.org/mt/102919731/3616948
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [mark.hatle@kernel.crashing.org]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
index 88acdb190e..cabbf2cc11 100644
--- a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
@@ -17,7 +17,7 @@  PV = "1.0+really0.15.0"
 
 GTKDOC_MESON_OPTION = "enable-gtk-doc"
 
-inherit meson pkgconfig gettext gtk-doc systemd python3native python3-dir python3targetconfig
+inherit meson pkgconfig gettext gtk-doc python3native python3-dir python3targetconfig
 
 do_install:append() {
         rmdir ${D}${root_prefix}${localstatedir}/run/${BPN} ${D}${root_prefix}${localstatedir}/run \
@@ -28,7 +28,7 @@  do_install:append() {
                 install -d ${D}${sysconfdir}/tmpfiles.d
                 echo "d /run/${BPN} - - - -" \
                 > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
-                echo "d /${localstatedir}/log/${BPN} 0755 root root -" \
+                echo "d ${localstatedir}/log/${BPN} 0755 root root -" \
                 >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
         fi
         ln -sf gst-client-1.0 ${D}${bindir}/gst-client
@@ -38,5 +38,3 @@  PACKAGES =+ "${PN}-python"
 
 FILES:${PN} += "${systemd_user_unitdir}"
 FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
-
-SYSTEMD_SERVICE:${PN} = "gstd.service"