[meta-oe,v2] influxdb: Upgrade to 1.8.10

Message ID 20211130025323.3019868-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,v2] influxdb: Upgrade to 1.8.10 | expand

Commit Message

Khem Raj Nov. 30, 2021, 2:53 a.m. UTC
Changes are here [1]

License-Update: Updated copyright info [2]

Fix sh interpreter path

[1] https://dl.influxdata.com/platform/nightlies/1.8/CHANGELOG.md
[2] https://github.com/influxdata/influxdb/commit/809ac4f0d5280a2391ed1af84e2a331d37525913#diff-c693279643b8cd5d248172d9c22cb7cf4ed163a3c98c8a3f69c2717edd3eacb7

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
v2: Use sed'ing instead of patching since packaging still catches
    files under .pc dir created by quilt

 .../influxdb/{influxdb_1.7.10.bb => influxdb_1.8.10.bb}  | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
 rename meta-oe/recipes-dbs/influxdb/{influxdb_1.7.10.bb => influxdb_1.8.10.bb} (84%)

Patch

diff --git a/meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb b/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
similarity index 84%
rename from meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb
rename to meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
index fa360b8d1d..55c2c41eef 100644
--- a/meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb
+++ b/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
@@ -2,7 +2,7 @@  DESCRIPTION = "InfluxDB is a time series database designed to handle high write
 HOMEPAGE = "https://www.influxdata.com/products/influxdb-overview/"
 
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=ba8146ad9cc2a128209983265136e06a"
+LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=f39a8d10930fb37bd59adabb3b9d0bd6"
 
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 
@@ -17,16 +17,16 @@  GO_INSTALL = "\
 "
 
 SRC_URI = "\
-    git://${GO_IMPORT};protocol=https;branch=1.7;destsuffix=${BPN}-${PV}/src/${GO_IMPORT} \
+    git://${GO_IMPORT};protocol=https;branch=1.8;destsuffix=${BPN}-${PV}/src/${GO_IMPORT} \
     file://influxdb \
     file://influxdb.conf \
 "
 
 SRC_URI:append:mipsarch = " file://0001-patch-term-module-for-mips-ispeed-ospeed-termios-abs.patch;patchdir=src/${GO_IMPORT}"
 
-SRCREV = "c958f436b2e538a88a7815aad721c7774a0b8f63"
+SRCREV = "688e697c51fd5353725da078555adbeff0363d01"
 
-inherit go-mod systemd update-rc.d useradd
+inherit go-mod pkgconfig systemd update-rc.d useradd
 
 USERADD_PACKAGES = "${PN}"
 USERADD_PARAM:${PN} = "--system -d /var/lib/influxdb -m -s /bin/nologin influxdb"
@@ -35,6 +35,7 @@  do_install:prepend() {
     rm ${B}/src/${GO_IMPORT}/build.py
     rm ${B}/src/${GO_IMPORT}/build.sh
     rm ${B}/src/${GO_IMPORT}/Dockerfile*
+    sed -i -e "s#usr/bin/sh#bin/sh#g" ${B}/src/${GO_IMPORT}/scripts/ci/run_perftest.sh
 }
 
 do_install:append() {