diff mbox series

[master/kirkstone,24/65] optee: Upgrade to upstream 3.17.0

Message ID 20220913035541.2364351-25-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Latest 2022.09 sync-up with Dunfell #1 | expand

Commit Message

Denys Dmytriyenko Sept. 13, 2022, 3:55 a.m. UTC
From: Andrew Davis <afd@ti.com>

Update to the latest upstream master which is 3.17.
We do this to add HUK and AM64x/AM62x support.
With this we need to also switch OPTEEMACHINE for AM64x/AM62x.

To build against the latest OP-TEE the support recipes need updated also.
Move these here into meta-ti so that builds will still work when not using
meta-arago-distro.

The fix patches do not look to be needed anymore.

While here switch to git checkout with https.

NOTE: The latest OP-TEE requires SYSFW 8.04+

Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-ti-bsp/conf/machine/include/am62xx.inc                  | 2 +-
 meta-ti-bsp/conf/machine/include/am64xx.inc                  | 2 +-
 meta-ti-bsp/recipes-security/optee/optee-client_%.bbappend   | 2 ++
 meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend | 2 ++
 .../recipes-security/optee/optee-os-tadevkit_%.bbappend      | 2 ++
 meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend       | 5 +++++
 meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend     | 3 +++
 7 files changed, 16 insertions(+), 2 deletions(-)
 create mode 100644 meta-ti-bsp/recipes-security/optee/optee-client_%.bbappend
 create mode 100644 meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend
 create mode 100644 meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend
 create mode 100644 meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend
diff mbox series

Patch

diff --git a/meta-ti-bsp/conf/machine/include/am62xx.inc b/meta-ti-bsp/conf/machine/include/am62xx.inc
index fff1312f..80df1844 100644
--- a/meta-ti-bsp/conf/machine/include/am62xx.inc
+++ b/meta-ti-bsp/conf/machine/include/am62xx.inc
@@ -21,5 +21,5 @@  do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
 TFA_BOARD = "lite"
 TFA_K3_SYSTEM_SUSPEND = "1"
 
-OPTEEMACHINE = "k3-am65x"
+OPTEEMACHINE = "k3-am62x"
 OPTEEOUTPUTMACHINE = "k3"
diff --git a/meta-ti-bsp/conf/machine/include/am64xx.inc b/meta-ti-bsp/conf/machine/include/am64xx.inc
index c5820986..87791ef7 100644
--- a/meta-ti-bsp/conf/machine/include/am64xx.inc
+++ b/meta-ti-bsp/conf/machine/include/am64xx.inc
@@ -21,5 +21,5 @@  do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
 do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
 
 TFA_BOARD = "lite"
-OPTEEMACHINE = "k3-am65x"
+OPTEEMACHINE = "k3-am64x"
 OPTEEOUTPUTMACHINE = "k3"
diff --git a/meta-ti-bsp/recipes-security/optee/optee-client_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-client_%.bbappend
new file mode 100644
index 00000000..109d451c
--- /dev/null
+++ b/meta-ti-bsp/recipes-security/optee/optee-client_%.bbappend
@@ -0,0 +1,2 @@ 
+PV:ti-soc = "3.17.0+git${SRCPV}"
+SRCREV:ti-soc = "a5c30b1277466a9bf85b62f45a6b00e79774e29c"
diff --git a/meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend
new file mode 100644
index 00000000..98b5bea4
--- /dev/null
+++ b/meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend
@@ -0,0 +1,2 @@ 
+PV:ti-soc = "3.17.0+git${SRCPV}"
+SRCREV:ti-soc = "65fc74309e12189ad5b6ce3ffec37c8011088a5a"
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend
new file mode 100644
index 00000000..4300c1a9
--- /dev/null
+++ b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend
@@ -0,0 +1,2 @@ 
+PV:ti-soc = "3.17.0+git${SRCPV}"
+SRCREV:ti-soc = "15a746d28d10df3d79d72bc9fe4a5a654b88bcca"
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
index d55bbc90..60e8c391 100644
--- a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
+++ b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
@@ -1,3 +1,8 @@ 
+PV:ti-soc = "3.17.0+git${SRCPV}"
+SRCREV:ti-soc = "15a746d28d10df3d79d72bc9fe4a5a654b88bcca"
+
+DEPENDS:append:ti-soc = " python3-cryptography-native"
+
 EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
 
 do_compile:prepend:ti-soc() {
diff --git a/meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend
new file mode 100644
index 00000000..4fbaa4c4
--- /dev/null
+++ b/meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend
@@ -0,0 +1,3 @@ 
+PV:ti-soc = "3.17.0+git${SRCPV}"
+SRCREV:ti-soc = "8a698baf9e8e010e4d8d52e6aded42dfc31e5b25"
+SRC_URI:ti-soc = "git://github.com/OP-TEE/optee_test.git;branch=master;protocol=https"