diff mbox series

linux-yocto: Enable team net driver

Message ID 20240509012206.517279-1-raj.khem@gmail.com
State Accepted, archived
Commit 7cd8e04b23b562746665577174799d42ded45d93
Headers show
Series linux-yocto: Enable team net driver | expand

Commit Message

Khem Raj May 9, 2024, 1:22 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/linux/linux-yocto_6.6.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Bruce Ashfield May 9, 2024, 3:16 a.m. UTC | #1
On Wed, May 8, 2024 at 9:22 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
>  meta/recipes-kernel/linux/linux-yocto_6.6.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta/recipes-kernel/linux/linux-yocto_6.6.bb b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> index 71bfbf9e032..4503ec94ae9 100644
> --- a/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> @@ -66,6 +66,7 @@ KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
>  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
>  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc features/nf_tables/nft_test.scc", "", d)}"
>  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc features/gpio/sim.scc", "", d)}"

We are getting quite a few of these now and that isn't a problem. But
I think we should
probably start putting comments above the enable lines so casual users
will know why
the various fragments are being enabled.

For example, I don't really know what the team driver is, and why
ptest needs it!

Bruce

> +KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/net/team/team.scc", "", d)}"
>  KERNEL_FEATURES:append:powerpc =" arch/powerpc/powerpc-debug.scc"
>  KERNEL_FEATURES:append:powerpc64 =" arch/powerpc/powerpc-debug.scc"
>  KERNEL_FEATURES:append:powerpc64le =" arch/powerpc/powerpc-debug.scc"
> --
> 2.45.0
>
Khem Raj May 9, 2024, 3:26 a.m. UTC | #2
On Wed, May 8, 2024 at 8:16 PM Bruce Ashfield <bruce.ashfield@gmail.com> wrote:
>
> On Wed, May 8, 2024 at 9:22 PM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> > ---
> >  meta/recipes-kernel/linux/linux-yocto_6.6.bb | 1 +
> >  1 file changed, 1 insertion(+)
> >
> > diff --git a/meta/recipes-kernel/linux/linux-yocto_6.6.bb b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> > index 71bfbf9e032..4503ec94ae9 100644
> > --- a/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> > +++ b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> > @@ -66,6 +66,7 @@ KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
> >  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
> >  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc features/nf_tables/nft_test.scc", "", d)}"
> >  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc features/gpio/sim.scc", "", d)}"
>
> We are getting quite a few of these now and that isn't a problem. But
> I think we should
> probably start putting comments above the enable lines so casual users
> will know why
> the various fragments are being enabled.
>
> For example, I don't really know what the team driver is, and why
> ptest needs it!

when we expand ptests for more than core layer, then certain packages
e.g. libteam in meta-oe [1] this config option is needed to be
enabled.

[1] https://git.openembedded.org/meta-openembedded/commit/?id=df35bef3ae6411900efdfc3ea5ade23820e9af2f

>
> Bruce
>
> > +KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/net/team/team.scc", "", d)}"
> >  KERNEL_FEATURES:append:powerpc =" arch/powerpc/powerpc-debug.scc"
> >  KERNEL_FEATURES:append:powerpc64 =" arch/powerpc/powerpc-debug.scc"
> >  KERNEL_FEATURES:append:powerpc64le =" arch/powerpc/powerpc-debug.scc"
> > --
> > 2.45.0
> >
>
>
> --
> - Thou shalt not follow the NULL pointer, for chaos and madness await
> thee at its end
> - "Use the force Harry" - Gandalf, Star Trek II
Bruce Ashfield May 9, 2024, 1:02 p.m. UTC | #3
On Wed, May 8, 2024 at 11:26 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Wed, May 8, 2024 at 8:16 PM Bruce Ashfield <bruce.ashfield@gmail.com> wrote:
> >
> > On Wed, May 8, 2024 at 9:22 PM Khem Raj <raj.khem@gmail.com> wrote:
> > >
> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> > > ---
> > >  meta/recipes-kernel/linux/linux-yocto_6.6.bb | 1 +
> > >  1 file changed, 1 insertion(+)
> > >
> > > diff --git a/meta/recipes-kernel/linux/linux-yocto_6.6.bb b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> > > index 71bfbf9e032..4503ec94ae9 100644
> > > --- a/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> > > +++ b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
> > > @@ -66,6 +66,7 @@ KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
> > >  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
> > >  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc features/nf_tables/nft_test.scc", "", d)}"
> > >  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc features/gpio/sim.scc", "", d)}"
> >
> > We are getting quite a few of these now and that isn't a problem. But
> > I think we should
> > probably start putting comments above the enable lines so casual users
> > will know why
> > the various fragments are being enabled.
> >
> > For example, I don't really know what the team driver is, and why
> > ptest needs it!
>
> when we expand ptests for more than core layer, then certain packages
> e.g. libteam in meta-oe [1] this config option is needed to be
> enabled.
>

Cool. I don't have any concerns with the enablement itself, I'd just prefer
that we put a line above it in the file to indicate what depends on that
configuration so there's no confusion later.

Bruce

> [1] https://git.openembedded.org/meta-openembedded/commit/?id=df35bef3ae6411900efdfc3ea5ade23820e9af2f
>
> >
> > Bruce
> >
> > > +KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/net/team/team.scc", "", d)}"
> > >  KERNEL_FEATURES:append:powerpc =" arch/powerpc/powerpc-debug.scc"
> > >  KERNEL_FEATURES:append:powerpc64 =" arch/powerpc/powerpc-debug.scc"
> > >  KERNEL_FEATURES:append:powerpc64le =" arch/powerpc/powerpc-debug.scc"
> > > --
> > > 2.45.0
> > >
> >
> >
> > --
> > - Thou shalt not follow the NULL pointer, for chaos and madness await
> > thee at its end
> > - "Use the force Harry" - Gandalf, Star Trek II
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto_6.6.bb b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
index 71bfbf9e032..4503ec94ae9 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
@@ -66,6 +66,7 @@  KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
 KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
 KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc features/nf_tables/nft_test.scc", "", d)}"
 KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc features/gpio/sim.scc", "", d)}"
+KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/net/team/team.scc", "", d)}"
 KERNEL_FEATURES:append:powerpc =" arch/powerpc/powerpc-debug.scc"
 KERNEL_FEATURES:append:powerpc64 =" arch/powerpc/powerpc-debug.scc"
 KERNEL_FEATURES:append:powerpc64le =" arch/powerpc/powerpc-debug.scc"