diff mbox series

python3: skip test_concurrent_futures/test_shutdown

Message ID 20240508171014.2679217-1-tgamblin@baylibre.com
State Accepted, archived
Commit fe22c66f4da87e7dca62dfbeec2185e4efcc31a9
Headers show
Series python3: skip test_concurrent_futures/test_shutdown | expand

Commit Message

Trevor Gamblin May 8, 2024, 5:10 p.m. UTC
These tests are causing hangs on the Autobuilder, so disable them for
now.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ...-test_shutdown-skip-problematic-test.patch | 46 +++++++++++++++++++
 .../recipes-devtools/python/python3_3.12.3.bb |  1 +
 2 files changed, 47 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3/0001-test_shutdown-skip-problematic-test.patch
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3/0001-test_shutdown-skip-problematic-test.patch b/meta/recipes-devtools/python/python3/0001-test_shutdown-skip-problematic-test.patch
new file mode 100644
index 00000000000..1d4cda18b16
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/0001-test_shutdown-skip-problematic-test.patch
@@ -0,0 +1,46 @@ 
+From 9d4cdbde100798ba9fa1cf3f82dbaf18fd10a543 Mon Sep 17 00:00:00 2001
+From: Trevor Gamblin <tgamblin@baylibre.com>
+Date: Wed, 8 May 2024 11:58:09 -0400
+Subject: [PATCH] test_shutdown: skip problematic test
+
+This test hangs frequently when run on the Autobuilder. Disable it in
+testing until the cause can be determined.
+
+Upstream-Status: Inappropriate [OE-Specific]
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+---
+ Lib/test/test_concurrent_futures/test_shutdown.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/Lib/test/test_concurrent_futures/test_shutdown.py b/Lib/test/test_concurrent_futures/test_shutdown.py
+index 7a4065afd4..6b878a48bf 100644
+--- a/Lib/test/test_concurrent_futures/test_shutdown.py
++++ b/Lib/test/test_concurrent_futures/test_shutdown.py
+@@ -20,6 +20,7 @@ def sleep_and_print(t, msg):
+     sys.stdout.flush()
+ 
+ 
++@unittest.skip("skipping problematic test")
+ class ExecutorShutdownTest:
+     def test_run_after_shutdown(self):
+         self.executor.shutdown()
+@@ -156,6 +157,7 @@ def timeout(_signum, _frame):
+             signal.signal(signal.SIGALRM, old_handler)
+ 
+ 
++@unittest.skip("skipping problematic test")
+ class ThreadPoolShutdownTest(ThreadPoolMixin, ExecutorShutdownTest, BaseTestCase):
+     def test_threads_terminate(self):
+         def acquire_lock(lock):
+@@ -252,6 +254,7 @@ def test_cancel_futures_wait_false(self):
+         self.assertIn(out.strip(), [b"apple", b""])
+ 
+ 
++@unittest.skip("skipping problematic test")
+ class ProcessPoolShutdownTest(ExecutorShutdownTest):
+     def test_processes_terminate(self):
+         def acquire_lock(lock):
+-- 
+2.45.0
+
diff --git a/meta/recipes-devtools/python/python3_3.12.3.bb b/meta/recipes-devtools/python/python3_3.12.3.bb
index 04558a64634..93709b207ce 100644
--- a/meta/recipes-devtools/python/python3_3.12.3.bb
+++ b/meta/recipes-devtools/python/python3_3.12.3.bb
@@ -30,6 +30,7 @@  SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
            file://0001-skip-no_stdout_fileno-test-due-to-load-variability.patch \
            file://0001-test_storlines-skip-due-to-load-variability.patch \
            file://0001-gh-114492-Initialize-struct-termios-before-calling-t.patch \
+           file://0001-test_shutdown-skip-problematic-test.patch \
            "
 
 SRC_URI:append:class-native = " \