diff mbox series

[2/6] arm: Handle nodistro in firmware deployment

Message ID 20240430162957.94499-3-emekcan.aras@arm.com
State New
Headers show
Series Add support for using the systemready layer to Corstone-1000 | expand

Commit Message

Emekcan Aras April 30, 2024, 4:29 p.m. UTC
From: Drew Reed <Drew.Reed@arm.com>

The nodistro settings in poky set the TMPDIR variable to include the
TCLIBC value so we need to spot that and swap the TCLIBC for the musl
one used in the firmware multiconfig.

Signed-off-by: Drew Reed <Drew.Reed@arm.com>
---
 meta-arm/recipes-bsp/images/firmware-deploy-image.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-arm/recipes-bsp/images/firmware-deploy-image.bb b/meta-arm/recipes-bsp/images/firmware-deploy-image.bb
index 76c82738..2f347f0b 100644
--- a/meta-arm/recipes-bsp/images/firmware-deploy-image.bb
+++ b/meta-arm/recipes-bsp/images/firmware-deploy-image.bb
@@ -15,7 +15,8 @@  do_install[noexec] = "1"
 FIRMWARE_BINARIES ?= ""
 
 do_deploy() {
-    firmware_loc="${TMPDIR}_${MACHINE}/deploy/images/${MACHINE}"
+    firmware_loc=$(echo "${TMPDIR}" | sed "s/${TCLIBC}/musl/")
+    firmware_loc="${firmware_loc}_${MACHINE}/deploy/images/${MACHINE}"
     for firmware in ${FIRMWARE_BINARIES}; do
         echo "cp -av ${firmware_loc}/${firmware} ${DEPLOYDIR}/"
         cp -av "${firmware_loc}/${firmware}" ${DEPLOYDIR}/