[14/26] python3-babel: Add recipe from meta-oe/meta-python

Message ID 20220317115700.993924-15-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 84e56f68e80b272a533646ce43a1f3bb13eed74f
Headers show
Series Add support for sphinx documentation generation | expand

Commit Message

Richard Purdie March 17, 2022, 11:56 a.m. UTC
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 .../python/python3-babel_2.9.1.bb             | 26 +++++++++++++++++++
 1 file changed, 26 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-babel_2.9.1.bb

Patch

diff --git a/meta/recipes-devtools/python/python3-babel_2.9.1.bb b/meta/recipes-devtools/python/python3-babel_2.9.1.bb
new file mode 100644
index 00000000000..11c8d60105a
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-babel_2.9.1.bb
@@ -0,0 +1,26 @@ 
+DESCRIPTION = "A collection of tools for internationalizing Python applications"
+HOMEPAGE = "http://babel.edgewall.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=05fb707293a85504aa67afc8ea34d747"
+
+SRC_URI[sha256sum] = "bc0c176f9f6a994582230df350aa6e05ba2ebe4b3ac317eab29d9be5d2768da0"
+
+PYPI_PACKAGE = "Babel"
+
+inherit pypi setuptools3
+
+CLEANBROKEN = "1"
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-codecs \
+    ${PYTHON_PN}-difflib \
+    ${PYTHON_PN}-distutils \
+    ${PYTHON_PN}-netserver \
+    ${PYTHON_PN}-numbers \
+    ${PYTHON_PN}-pickle \
+    ${PYTHON_PN}-pytz \
+    ${PYTHON_PN}-shell \
+    ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"