[meta-python,1/2] python3-distro: Upgrade 1.6.0 -> 1.7.0

Message ID 20220222121158.3510277-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/2] python3-distro: Upgrade 1.6.0 -> 1.7.0 | expand

Commit Message

Leon Anavi Feb. 22, 2022, 12:11 p.m. UTC
Upgrade to release 1.7.0:

- Dropped support for EOL Pythons 2.7, 3.4 and 3.5
- Dropped support for LSB and uname back-ends when --root-dir is
  specified
- Moved distro.py to src/distro/distro.py
- Documented that distro.version() can return an empty string on
  rolling releases
- Documented support for Python 3.10
- Added official support for Rocky Linux distribution
- Added a shebang to distro.py to allow standalone execution
- Added support for AIX platforms
- Added compliance for PEP-561
- Fixed include_uname parameter oversight
- Fixed crash when uname -rs output is empty
- Fixed Amazon Linux identifier in distro.id() documentation
- Fixed OpenSuse >= 15 support
- Fixed encoding issues when opening distro release files
- Fixed linux_distribution regression

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-distro_1.6.0.bb => python3-distro_1.7.0.bb} | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-distro_1.6.0.bb => python3-distro_1.7.0.bb} (56%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-distro_1.6.0.bb b/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
similarity index 56%
rename from meta-python/recipes-devtools/python/python3-distro_1.6.0.bb
rename to meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
index 8aa225567..f069234d1 100644
--- a/meta-python/recipes-devtools/python/python3-distro_1.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-distro_1.7.0.bb
@@ -5,8 +5,15 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
 
 PYPI_PACKAGE = "distro"
 
-SRC_URI[sha256sum] = "83f5e5a09f9c5f68f60173de572930effbcc0287bb84fdc4426cb4168c088424"
+SRC_URI[sha256sum] = "151aeccf60c216402932b52e40ee477a939f8d58898927378a02abbe852c1c39"
 
 inherit pypi setuptools3
 
+RDEPENDS:${PN} = "\
+	${PYTHON_PN}-core \
+	${PYTHON_PN}-json \
+	${PYTHON_PN}-logging \
+	${PYTHON_PN}-shell \
+"
+
 BBCLASSEXTEND = "native nativesdk"