diff mbox series

python3-more-itertools: upgrade 9.1.0 -> 10.0.0

Message ID 20230730190326.2335908-1-tim.orling@konsulko.com
State Accepted, archived
Commit 9351489f3fd9a01f1e74b4f209df01aeffe55c8f
Headers show
Series python3-more-itertools: upgrade 9.1.0 -> 10.0.0 | expand

Commit Message

Tim Orling July 30, 2023, 7:03 p.m. UTC
https://more-itertools.readthedocs.io/en/stable/versions.html

10.0.0
* Potentially breaking changes
  - Python 3.7 support was dropped, since it went EOL on 2023-06-27
  - batched() no longer issues a DeprecationWarning; it is now an alias
    for itertools.batched for Python 3.12+
  - batched() and matmul() now yield tuples instead of lists
* New functions
  - combination_with_replacement_index() (thanks to Schoyen)
  - nth_combination_with_replacement() (thanks to Schoyen)
  - polynomial_eval() (from the Python itertools docs)
  - polynomial_derivative() (from the Python itertools docs)
  - sum_of_squares() (from the Python itertools docs)
* Changes to existing functions
  - seekable() now has relative_seek method (thanks to karlb)
  - chunked_even() was optimized (thanks to elliotwutingfeng)
  - numeric_range() was optimized (thanks to eltoder)
  - duplicates_justseen(), pairwise(), partial_product(), and partition()
    were updated and optimized (thanks to pochmann)
  - unique_in_window() had its implementation updated (thanks to
    elliotwutingfeng)
  - iterate() now breaks when its func argument raises StopIteration (thanks
    to jrebiffe)
* Other changes
  - Some documentation and testing issues were fixed (thanks to lonnen and
    XuehaiPan)

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
All ptests pass on core-image-ptest-python3-more-itertools for qemux86-64

 ...more-itertools_9.1.0.bb => python3-more-itertools_10.0.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-more-itertools_9.1.0.bb => python3-more-itertools_10.0.0.bb} (87%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb b/meta/recipes-devtools/python/python3-more-itertools_10.0.0.bb
similarity index 87%
rename from meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb
rename to meta/recipes-devtools/python/python3-more-itertools_10.0.0.bb
index 8c33b7161bc..e07d4b78606 100644
--- a/meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb
+++ b/meta/recipes-devtools/python/python3-more-itertools_10.0.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/erikrose/more-itertools"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
 
-SRC_URI[sha256sum] = "cabaa341ad0389ea83c17a94566a53ae4c9d07349861ecb14dc6d0345cf9ac5d"
+SRC_URI[sha256sum] = "cd65437d7c4b615ab81c0640c0480bc29a550ea032891977681efd28344d51e1"
 
 inherit pypi python_flit_core ptest