diff mbox series

gator-daemon: bump to 8.3.0

Message ID 20230207151952.94769-1-peron.clem@gmail.com
State New
Headers show
Series gator-daemon: bump to 8.3.0 | expand

Commit Message

Clément Péron Feb. 7, 2023, 3:19 p.m. UTC
Bump gator daemon to 8.3.0.

Drop no more required patches
Move to CMake
Add a patch to fix template compilation

Signed-off-by: Clément Péron <peron.clem@gmail.com>
---
 ...rf-fix-no-matching-function-for-call.patch | 27 ++++++++++++++++
 .../0001-Include-missing-cstdint.patch        | 32 -------------------
 .../0001-daemon-mxml-Define-_GNU_SOURCE.patch | 31 ------------------
 ...-daemon_7.8.0.bb => gator-daemon_8.3.0.bb} | 21 ++++++------
 4 files changed, 36 insertions(+), 75 deletions(-)
 create mode 100644 meta-arm/recipes-devtools/gator-daemon/files/0001-daemon-agents-perf-fix-no-matching-function-for-call.patch
 delete mode 100644 meta-arm/recipes-devtools/gator-daemon/gator-daemon/0001-Include-missing-cstdint.patch
 delete mode 100644 meta-arm/recipes-devtools/gator-daemon/gator-daemon/0001-daemon-mxml-Define-_GNU_SOURCE.patch
 rename meta-arm/recipes-devtools/gator-daemon/{gator-daemon_7.8.0.bb => gator-daemon_8.3.0.bb} (54%)

Comments

Ross Burton Feb. 8, 2023, 1:31 p.m. UTC | #1
On 7 Feb 2023, at 15:19, Clément Péron via lists.yoctoproject.org <peron.clem=gmail.com@lists.yoctoproject.org> wrote:
> +DEPENDS = "boost libmxml protobuf protobuf-native"

This does mean that the CI needs work because libmxml is in meta-oe, not oe-core.

For example, https://gitlab.com/jonmason00/meta-arm/-/jobs/3735010875

Ross
Jon Mason Feb. 13, 2023, 5:09 p.m. UTC | #2
On Wed, Feb 08, 2023 at 01:31:54PM +0000, Ross Burton wrote:
> On 7 Feb 2023, at 15:19, Cl�ment P�ron via lists.yoctoproject.org <peron.clem=gmail.com@lists.yoctoproject.org> wrote:
> > +DEPENDS = "boost libmxml protobuf protobuf-native"
> 
> This does mean that the CI needs work because libmxml is in meta-oe, not oe-core.
> 
> For example, https://gitlab.com/jonmason00/meta-arm/-/jobs/3735010875
> 
> Ross
> 

I tried adding ci/meta-openembedded.yml to ci/base.yml to see if that
would be sufficient to get this patch working, but I'm seeing another
issue:
   None of the required 'mxml>=3' found


Thanks,
Jon
Clément Péron Feb. 21, 2023, 10:23 a.m. UTC | #3
Hi,

On Mon, 13 Feb 2023 at 18:09, Jon Mason <jdmason@kudzu.us> wrote:
>
> On Wed, Feb 08, 2023 at 01:31:54PM +0000, Ross Burton wrote:
> > On 7 Feb 2023, at 15:19, Clément Péron via lists.yoctoproject.org <peron.clem=gmail.com@lists.yoctoproject.org> wrote:
> > > +DEPENDS = "boost libmxml protobuf protobuf-native"
> >
> > This does mean that the CI needs work because libmxml is in meta-oe, not oe-core.
> >
> > For example, https://gitlab.com/jonmason00/meta-arm/-/jobs/3735010875
> >
> > Ross
> >
>
> I tried adding ci/meta-openembedded.yml to ci/base.yml to see if that
> would be sufficient to get this patch working, but I'm seeing another
> issue:
>    None of the required 'mxml>=3' found

I tested on hardknott but indeed in kirkstone it failed due to missing
a DEPENDS on pkgconfig-native to allow cmake to find the mxml lib.

I will send a v2.

Regards,
Clement
>
>
> Thanks,
> Jon
diff mbox series

Patch

diff --git a/meta-arm/recipes-devtools/gator-daemon/files/0001-daemon-agents-perf-fix-no-matching-function-for-call.patch b/meta-arm/recipes-devtools/gator-daemon/files/0001-daemon-agents-perf-fix-no-matching-function-for-call.patch
new file mode 100644
index 00000000..5c7b0bc3
--- /dev/null
+++ b/meta-arm/recipes-devtools/gator-daemon/files/0001-daemon-agents-perf-fix-no-matching-function-for-call.patch
@@ -0,0 +1,27 @@ 
+From 28f93c8fac4b3565db757010de01974caff74c8d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Cl=C3=A9ment=20P=C3=A9ron?= <cpe@outsight.tech>
+Date: Tue, 7 Feb 2023 13:03:29 +0100
+Subject: [PATCH] fix
+
+---
+ daemon/agents/perf/capture_configuration.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/daemon/agents/perf/capture_configuration.cpp b/daemon/agents/perf/capture_configuration.cpp
+index 84b04de..6817d6d 100644
+--- a/daemon/agents/perf/capture_configuration.cpp
++++ b/daemon/agents/perf/capture_configuration.cpp
+@@ -49,8 +49,8 @@ namespace agents::perf {
+             msg.set_has_exclude_callchain_kernel(perf_config.has_exclude_callchain_kernel);
+         }
+ 
+-        template<typename T, typename H, typename R>
+-        constexpr void set_if_not_null(T const * ptr, H & host, R (H::*fn)(T const *))
++        template<typename H, typename T = char, typename R = void>
++        constexpr void set_if_not_null(const T * ptr, H & host, R (H::*fn)(const std::string &))
+         {
+             if (ptr != nullptr) {
+                 (host.*fn)(ptr);
+-- 
+2.34.1
+
diff --git a/meta-arm/recipes-devtools/gator-daemon/gator-daemon/0001-Include-missing-cstdint.patch b/meta-arm/recipes-devtools/gator-daemon/gator-daemon/0001-Include-missing-cstdint.patch
deleted file mode 100644
index 294f804f..00000000
--- a/meta-arm/recipes-devtools/gator-daemon/gator-daemon/0001-Include-missing-cstdint.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From 87745a6cad0f7819ac8f8d3826f5e228ebd843c5 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 2 Feb 2023 16:39:26 -0800
-Subject: [PATCH] Include missing <cstdint>
-
-gcc 13 moved some includes around and as a result <cstdint> is no
-longer transitively included [1]. Explicitly include it
-for uintXX_t.
-
-[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
-
-Upstream-Status: Submitted [https://github.com/ARM-software/gator/pull/40]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- daemon/xml/CurrentConfigXML.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/daemon/xml/CurrentConfigXML.h b/daemon/xml/CurrentConfigXML.h
-index 0b239fd..d9047e3 100644
---- a/daemon/xml/CurrentConfigXML.h
-+++ b/daemon/xml/CurrentConfigXML.h
-@@ -1,6 +1,7 @@
- /* Copyright (C) 2020-2021 by Arm Limited. All rights reserved. */
- #pragma once
- 
-+#include <cstdint>
- #include <set>
- #include <string>
- 
--- 
-2.39.1
-
diff --git a/meta-arm/recipes-devtools/gator-daemon/gator-daemon/0001-daemon-mxml-Define-_GNU_SOURCE.patch b/meta-arm/recipes-devtools/gator-daemon/gator-daemon/0001-daemon-mxml-Define-_GNU_SOURCE.patch
deleted file mode 100644
index d2460434..00000000
--- a/meta-arm/recipes-devtools/gator-daemon/gator-daemon/0001-daemon-mxml-Define-_GNU_SOURCE.patch
+++ /dev/null
@@ -1,31 +0,0 @@ 
-From 04e2e924c3ab8da41343277746804dbcd7bf520d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 13 Aug 2022 16:49:52 -0700
-Subject: [PATCH] daemon/mxml: Define _GNU_SOURCE
-
-This file uses vasprintf() which is defined only with _GNU_SOURCE
-feature macro is on.
-
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- daemon/mxml/mxml-string.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/daemon/mxml/mxml-string.c b/daemon/mxml/mxml-string.c
-index 678aeb9..c9cd153 100644
---- a/daemon/mxml/mxml-string.c
-+++ b/daemon/mxml/mxml-string.c
-@@ -13,6 +13,8 @@
-  * Include necessary headers...
-  */
- 
-+#define _GNU_SOURCE
-+
- #include "config.h"
- 
- 
--- 
-2.37.2
-
diff --git a/meta-arm/recipes-devtools/gator-daemon/gator-daemon_7.8.0.bb b/meta-arm/recipes-devtools/gator-daemon/gator-daemon_8.3.0.bb
similarity index 54%
rename from meta-arm/recipes-devtools/gator-daemon/gator-daemon_7.8.0.bb
rename to meta-arm/recipes-devtools/gator-daemon/gator-daemon_8.3.0.bb
index 6188b07e..3a0e53cd 100644
--- a/meta-arm/recipes-devtools/gator-daemon/gator-daemon_7.8.0.bb
+++ b/meta-arm/recipes-devtools/gator-daemon/gator-daemon_8.3.0.bb
@@ -8,28 +8,25 @@  HOMEPAGE = "https://github.com/ARM-software/gator"
 # configuration requirement specified here:
 # https://github.com/ARM-software/gator#kernel-configuration
 
-LICENSE = "GPL-2.0-only & LGPL-2.1-or-later & Apache-2.0"
+LICENSE = "GPL-2.0-only & LGPL-2.1-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                     file://libsensors/COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
-                    file://mxml/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
                     file://k/perf_event.h;endline=14;md5=e548bf30a60b2ed11ef2dcf7bfdac230 \
                    "
 
-SRCREV = "6a944e7ee1f1c3ab9b2a57efd24c58503122db02"
+SRCREV = "17ae804323e0ce451f5df23d06416dadddc337a5"
 SRC_URI = "git://github.com/ARM-software/gator.git;protocol=http;branch=main;protocol=https \
-           file://0001-daemon-mxml-Define-_GNU_SOURCE.patch;striplevel=2 \
-           file://0001-Include-missing-cstdint.patch;striplevel=2 \
+           file://0001-daemon-agents-perf-fix-no-matching-function-for-call.patch;striplevel=2 \
           "
 
 S = "${WORKDIR}/git/daemon"
 
+DEPENDS = "boost libmxml protobuf protobuf-native"
+
 COMPATIBLE_HOST = "aarch64.*-linux"
 
-EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -D_DEFAULT_SOURCE -DETCDIR=\"${sysconfdir}\"' \
-                'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}' \
-                'CXXFLAGS=${CXXFLAGS} ${TARGET_CC_ARCH} -fno-rtti' CC='${CC}' CXX='${CXX}' V=1"
+inherit cmake
+
+EXTRA_OECMAKE += "-DENABLE_VCPKG=OFF -DGATOR_INSTALL_PREFIX=./bin"
 
-do_install() {
-        install -d ${D}${sbindir}
-        install -m 0755 ${S}/gatord ${D}${sbindir}/gatord
-}
+FILES_${PN} = "/usr/bin/daemon"