diff mbox series

[meta-ti,master/dunfell,RFC] conf: machine: j721s2-evm: Add support for J721S2 HS-FS

Message ID 20230125133754.692-1-sinthu.raja@ti.com
State RFC
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master/dunfell,RFC] conf: machine: j721s2-evm: Add support for J721S2 HS-FS | expand

Commit Message

Sinthu Raja M Jan. 25, 2023, 1:37 p.m. UTC
From: Sinthu Raja <sinthu.raja@ti.com>

Add the basic J721S2 HS-FS configuration.
    - Add configurations to support both HS-FS and GP.
    - Add ti-sci-firmware overrides.

Signed-off-by: Aniket Limaye <a-limaye@ti.com>
Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
---
 conf/machine/j721s2-evm-k3r5-gp.conf        | 20 ++++++++++++++++++++
 conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf | 15 +++++++++++++++
 conf/machine/j721s2-evm.conf                | 12 ++++++++++++
 conf/multiconfig/k3r5-sr1-hs-fs.conf        |  3 +++
 conf/multiconfig/k3r5-sr1.conf              |  3 +++
 recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb      |  3 ++-
 6 files changed, 55 insertions(+), 1 deletion(-)
 create mode 100644 conf/machine/j721s2-evm-k3r5-gp.conf
 create mode 100644 conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
 create mode 100644 conf/multiconfig/k3r5-sr1-hs-fs.conf
 create mode 100644 conf/multiconfig/k3r5-sr1.conf

Comments

Andrew Davis Jan. 25, 2023, 4:14 p.m. UTC | #1
On 1/25/23 7:37 AM, Sinthu Raja M via lists.yoctoproject.org wrote:
> From: Sinthu Raja <sinthu.raja@ti.com>
> 
> Add the basic J721S2 HS-FS configuration.
>      - Add configurations to support both HS-FS and GP.
>      - Add ti-sci-firmware overrides.
> 
> Signed-off-by: Aniket Limaye <a-limaye@ti.com>
> Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
> ---
>   conf/machine/j721s2-evm-k3r5-gp.conf        | 20 ++++++++++++++++++++
>   conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf | 15 +++++++++++++++
>   conf/machine/j721s2-evm.conf                | 12 ++++++++++++
>   conf/multiconfig/k3r5-sr1-hs-fs.conf        |  3 +++
>   conf/multiconfig/k3r5-sr1.conf              |  3 +++
>   recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb      |  3 ++-
>   6 files changed, 55 insertions(+), 1 deletion(-)
>   create mode 100644 conf/machine/j721s2-evm-k3r5-gp.conf
>   create mode 100644 conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
>   create mode 100644 conf/multiconfig/k3r5-sr1-hs-fs.conf
>   create mode 100644 conf/multiconfig/k3r5-sr1.conf
> 
> diff --git a/conf/machine/j721s2-evm-k3r5-gp.conf b/conf/machine/j721s2-evm-k3r5-gp.conf
> new file mode 100644
> index 00000000..06456ef7
> --- /dev/null
> +++ b/conf/machine/j721s2-evm-k3r5-gp.conf
> @@ -0,0 +1,20 @@
> +#@TYPE: Machine
> +#@NAME: J721S2 GP EVM (R5F)
> +#@DESCRIPTION: Machine configuration for the TI J721S2 GP EVM (R5F core)
> +
> +# Booting GP requires different SYSFW, the rest is handled at runtime
> +
> +require conf/machine/include/k3r5.inc
> +SOC_FAMILY_append = ":k3r5-gp"
> +
> +SYSFW_SOC = "j721s2"
> +SYSFW_CONFIG = "evm"
> +SYSFW_SUFFIX = "gp"
> +SYSFW_TIBOOT3_SYMLINK = "tiboot3.bin"
> +
> +UBOOT_MACHINE = "j721s2_evm_r5_defconfig"
> +
> +SPL_BINARY = ""
> +UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
> +UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
> +UBOOT_SYMLINK = "u-boot-r5spl-gp.${UBOOT_SUFFIX}"
> diff --git a/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf b/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
> new file mode 100644
> index 00000000..786338a9
> --- /dev/null
> +++ b/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
> @@ -0,0 +1,15 @@
> +#@TYPE: Machine
> +#@NAME: J721S2 HS-FS EVM (R5F)
> +#@DESCRIPTION: Machine configuration for the TI J721S2 HS-FS EVM (R5F core)
> +
> +# Booting HS-FS requires different SYSFW, the rest is handled at runtime
> +
> +require conf/machine/include/k3r5.inc
> +SOC_FAMILY_append = ":k3r5-sr1-hs-fs"
> +
> +SYSFW_SOC = "j721s2"
> +SYSFW_CONFIG = "evm"
> +SYSFW_SUFFIX = "hs-fs"
> +SYSFW_TIBOOT3_SYMLINK = ""
> +
> +UBOOT_MACHINE = "j721s2_evm_r5_defconfig"
> diff --git a/conf/machine/j721s2-evm.conf b/conf/machine/j721s2-evm.conf
> index 1ed693c5..bf1c82a1 100644
> --- a/conf/machine/j721s2-evm.conf
> +++ b/conf/machine/j721s2-evm.conf
> @@ -25,3 +25,15 @@ UBOOT_MACHINE = "j721s2_evm_a72_defconfig"
>   
>   do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
>   do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
> +
> +# Since default tiboot3.bin on AM64x is for SR2.0 HS-FS, add a version for GP

This comment and the one below are not right, SoC name, version, and HS types
are all wrong.

> +BBMULTICONFIG = "k3r5-sr1-hs-fs"
> +IMAGE_BOOT_FILES += " tiboot3-j721s2-hs-fs-evm.bin"
> +do_image_wic[mcdepends] = "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
> +do_image_tar[mcdepends] = "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
> +
> +# Since default tiboot3.bin on AM64x is for SR2.0 HS-FS, add a version for GP
> +BBMULTICONFIG += "k3r5-gp"
> +IMAGE_BOOT_FILES += " tiboot3-j721s2-gp-evm.bin"
> +do_image_wic[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
> +do_image_tar[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
> diff --git a/conf/multiconfig/k3r5-sr1-hs-fs.conf b/conf/multiconfig/k3r5-sr1-hs-fs.conf
> new file mode 100644
> index 00000000..2fa28c95
> --- /dev/null
> +++ b/conf/multiconfig/k3r5-sr1-hs-fs.conf
> @@ -0,0 +1,3 @@
> +require k3r5-sr1.conf

Why "-sr1", do you expect an SR2 anytime soon?

Andrew

> +
> +MACHINE_append = "-hs-fs"
> diff --git a/conf/multiconfig/k3r5-sr1.conf b/conf/multiconfig/k3r5-sr1.conf
> new file mode 100644
> index 00000000..2b87de8a
> --- /dev/null
> +++ b/conf/multiconfig/k3r5-sr1.conf
> @@ -0,0 +1,3 @@
> +require k3r5.conf
> +
> +MACHINE_append = "-sr1"
> diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> index 0fb3a832..39e5907f 100644
> --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> @@ -33,7 +33,8 @@ SYSFW_PREFIX_j7-hs-evm-k3r5 = "fs"
>   SYSFW_PREFIX_j7-hs-evm-k3r5-sr1-1 = "fs"
>   SYSFW_PREFIX_j7200-evm-k3r5 = "fs"
>   SYSFW_PREFIX_j7200-hs-evm-k3r5 = "fs"
> -SYSFW_PREFIX_j721s2-evm-k3r5 = "fs"
> +SYSFW_PREFIX_j721s2-evm-k3r5-gp = "fs"
> +SYSFW_PREFIX_j721s2-evm-k3r5-sr1-hs-fs = "fs"
>   SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
>   SYSFW_PREFIX_j784s4-evm-k3r5 = "fs"
>   SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#15651): https://lists.yoctoproject.org/g/meta-ti/message/15651
> Mute This Topic: https://lists.yoctoproject.org/mt/96519981/3619733
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [afd@ti.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Sinthu Raja M Jan. 25, 2023, 5:12 p.m. UTC | #2
+Goswami, Piyali

On Wed, Jan 25, 2023 at 9:44 PM Andrew Davis <afd@ti.com> wrote:
>
> On 1/25/23 7:37 AM, Sinthu Raja M via lists.yoctoproject.org wrote:
> > From: Sinthu Raja <sinthu.raja@ti.com>
> >
> > Add the basic J721S2 HS-FS configuration.
> >      - Add configurations to support both HS-FS and GP.
> >      - Add ti-sci-firmware overrides.
> >
> > Signed-off-by: Aniket Limaye <a-limaye@ti.com>
> > Signed-off-by: Sinthu Raja <sinthu.raja@ti.com>
> > ---
> >   conf/machine/j721s2-evm-k3r5-gp.conf        | 20 ++++++++++++++++++++
> >   conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf | 15 +++++++++++++++
> >   conf/machine/j721s2-evm.conf                | 12 ++++++++++++
> >   conf/multiconfig/k3r5-sr1-hs-fs.conf        |  3 +++
> >   conf/multiconfig/k3r5-sr1.conf              |  3 +++
> >   recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb      |  3 ++-
> >   6 files changed, 55 insertions(+), 1 deletion(-)
> >   create mode 100644 conf/machine/j721s2-evm-k3r5-gp.conf
> >   create mode 100644 conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
> >   create mode 100644 conf/multiconfig/k3r5-sr1-hs-fs.conf
> >   create mode 100644 conf/multiconfig/k3r5-sr1.conf
> >
> > diff --git a/conf/machine/j721s2-evm-k3r5-gp.conf b/conf/machine/j721s2-evm-k3r5-gp.conf
> > new file mode 100644
> > index 00000000..06456ef7
> > --- /dev/null
> > +++ b/conf/machine/j721s2-evm-k3r5-gp.conf
> > @@ -0,0 +1,20 @@
> > +#@TYPE: Machine
> > +#@NAME: J721S2 GP EVM (R5F)
> > +#@DESCRIPTION: Machine configuration for the TI J721S2 GP EVM (R5F core)
> > +
> > +# Booting GP requires different SYSFW, the rest is handled at runtime
> > +
> > +require conf/machine/include/k3r5.inc
> > +SOC_FAMILY_append = ":k3r5-gp"
> > +
> > +SYSFW_SOC = "j721s2"
> > +SYSFW_CONFIG = "evm"
> > +SYSFW_SUFFIX = "gp"
> > +SYSFW_TIBOOT3_SYMLINK = "tiboot3.bin"
> > +
> > +UBOOT_MACHINE = "j721s2_evm_r5_defconfig"
> > +
> > +SPL_BINARY = ""
> > +UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
> > +UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
> > +UBOOT_SYMLINK = "u-boot-r5spl-gp.${UBOOT_SUFFIX}"
> > diff --git a/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf b/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
> > new file mode 100644
> > index 00000000..786338a9
> > --- /dev/null
> > +++ b/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
> > @@ -0,0 +1,15 @@
> > +#@TYPE: Machine
> > +#@NAME: J721S2 HS-FS EVM (R5F)
> > +#@DESCRIPTION: Machine configuration for the TI J721S2 HS-FS EVM (R5F core)
> > +
> > +# Booting HS-FS requires different SYSFW, the rest is handled at runtime
> > +
> > +require conf/machine/include/k3r5.inc
> > +SOC_FAMILY_append = ":k3r5-sr1-hs-fs"
> > +
> > +SYSFW_SOC = "j721s2"
> > +SYSFW_CONFIG = "evm"
> > +SYSFW_SUFFIX = "hs-fs"
> > +SYSFW_TIBOOT3_SYMLINK = ""
> > +
> > +UBOOT_MACHINE = "j721s2_evm_r5_defconfig"
> > diff --git a/conf/machine/j721s2-evm.conf b/conf/machine/j721s2-evm.conf
> > index 1ed693c5..bf1c82a1 100644
> > --- a/conf/machine/j721s2-evm.conf
> > +++ b/conf/machine/j721s2-evm.conf
> > @@ -25,3 +25,15 @@ UBOOT_MACHINE = "j721s2_evm_a72_defconfig"
> >
> >   do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
> >   do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
> > +
> > +# Since default tiboot3.bin on AM64x is for SR2.0 HS-FS, add a version for GP
>
> This comment and the one below are not right, SoC name, version, and HS types
> are all wrong.
My Bad! Will update this.
>
> > +BBMULTICONFIG = "k3r5-sr1-hs-fs"
> > +IMAGE_BOOT_FILES += " tiboot3-j721s2-hs-fs-evm.bin"
> > +do_image_wic[mcdepends] = "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
> > +do_image_tar[mcdepends] = "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
> > +
> > +# Since default tiboot3.bin on AM64x is for SR2.0 HS-FS, add a version for GP
> > +BBMULTICONFIG += "k3r5-gp"
> > +IMAGE_BOOT_FILES += " tiboot3-j721s2-gp-evm.bin"
> > +do_image_wic[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
> > +do_image_tar[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
> > diff --git a/conf/multiconfig/k3r5-sr1-hs-fs.conf b/conf/multiconfig/k3r5-sr1-hs-fs.conf
> > new file mode 100644
> > index 00000000..2fa28c95
> > --- /dev/null
> > +++ b/conf/multiconfig/k3r5-sr1-hs-fs.conf
> > @@ -0,0 +1,3 @@
> > +require k3r5-sr1.conf
>
> Why "-sr1", do you expect an SR2 anytime soon?
>
When discussed with Piyali got to know that there may be another
revision. So to avoid naming conventions in the future, we added SR1.

> Andrew
>
> > +
> > +MACHINE_append = "-hs-fs"
> > diff --git a/conf/multiconfig/k3r5-sr1.conf b/conf/multiconfig/k3r5-sr1.conf
> > new file mode 100644
> > index 00000000..2b87de8a
> > --- /dev/null
> > +++ b/conf/multiconfig/k3r5-sr1.conf
> > @@ -0,0 +1,3 @@
> > +require k3r5.conf
> > +
> > +MACHINE_append = "-sr1"
> > diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> > index 0fb3a832..39e5907f 100644
> > --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> > +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> > @@ -33,7 +33,8 @@ SYSFW_PREFIX_j7-hs-evm-k3r5 = "fs"
> >   SYSFW_PREFIX_j7-hs-evm-k3r5-sr1-1 = "fs"
> >   SYSFW_PREFIX_j7200-evm-k3r5 = "fs"
> >   SYSFW_PREFIX_j7200-hs-evm-k3r5 = "fs"
> > -SYSFW_PREFIX_j721s2-evm-k3r5 = "fs"
> > +SYSFW_PREFIX_j721s2-evm-k3r5-gp = "fs"
> > +SYSFW_PREFIX_j721s2-evm-k3r5-sr1-hs-fs = "fs"
> >   SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
> >   SYSFW_PREFIX_j784s4-evm-k3r5 = "fs"
> >   SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs"
> >
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#15651): https://lists.yoctoproject.org/g/meta-ti/message/15651
> > Mute This Topic: https://lists.yoctoproject.org/mt/96519981/3619733
> > Group Owner: meta-ti+owner@lists.yoctoproject.org
> > Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [afd@ti.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
diff mbox series

Patch

diff --git a/conf/machine/j721s2-evm-k3r5-gp.conf b/conf/machine/j721s2-evm-k3r5-gp.conf
new file mode 100644
index 00000000..06456ef7
--- /dev/null
+++ b/conf/machine/j721s2-evm-k3r5-gp.conf
@@ -0,0 +1,20 @@ 
+#@TYPE: Machine
+#@NAME: J721S2 GP EVM (R5F)
+#@DESCRIPTION: Machine configuration for the TI J721S2 GP EVM (R5F core)
+
+# Booting GP requires different SYSFW, the rest is handled at runtime
+
+require conf/machine/include/k3r5.inc
+SOC_FAMILY_append = ":k3r5-gp"
+
+SYSFW_SOC = "j721s2"
+SYSFW_CONFIG = "evm"
+SYSFW_SUFFIX = "gp"
+SYSFW_TIBOOT3_SYMLINK = "tiboot3.bin"
+
+UBOOT_MACHINE = "j721s2_evm_r5_defconfig"
+
+SPL_BINARY = ""
+UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
+UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK = "u-boot-r5spl-gp.${UBOOT_SUFFIX}"
diff --git a/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf b/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
new file mode 100644
index 00000000..786338a9
--- /dev/null
+++ b/conf/machine/j721s2-evm-k3r5-sr1-hs-fs.conf
@@ -0,0 +1,15 @@ 
+#@TYPE: Machine
+#@NAME: J721S2 HS-FS EVM (R5F)
+#@DESCRIPTION: Machine configuration for the TI J721S2 HS-FS EVM (R5F core)
+
+# Booting HS-FS requires different SYSFW, the rest is handled at runtime
+
+require conf/machine/include/k3r5.inc
+SOC_FAMILY_append = ":k3r5-sr1-hs-fs"
+
+SYSFW_SOC = "j721s2"
+SYSFW_CONFIG = "evm"
+SYSFW_SUFFIX = "hs-fs"
+SYSFW_TIBOOT3_SYMLINK = ""
+
+UBOOT_MACHINE = "j721s2_evm_r5_defconfig"
diff --git a/conf/machine/j721s2-evm.conf b/conf/machine/j721s2-evm.conf
index 1ed693c5..bf1c82a1 100644
--- a/conf/machine/j721s2-evm.conf
+++ b/conf/machine/j721s2-evm.conf
@@ -25,3 +25,15 @@  UBOOT_MACHINE = "j721s2_evm_a72_defconfig"
 
 do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
 do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
+
+# Since default tiboot3.bin on AM64x is for SR2.0 HS-FS, add a version for GP
+BBMULTICONFIG = "k3r5-sr1-hs-fs"
+IMAGE_BOOT_FILES += " tiboot3-j721s2-hs-fs-evm.bin"
+do_image_wic[mcdepends] = "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
+do_image_tar[mcdepends] = "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
+
+# Since default tiboot3.bin on AM64x is for SR2.0 HS-FS, add a version for GP
+BBMULTICONFIG += "k3r5-gp"
+IMAGE_BOOT_FILES += " tiboot3-j721s2-gp-evm.bin"
+do_image_wic[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
+do_image_tar[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
diff --git a/conf/multiconfig/k3r5-sr1-hs-fs.conf b/conf/multiconfig/k3r5-sr1-hs-fs.conf
new file mode 100644
index 00000000..2fa28c95
--- /dev/null
+++ b/conf/multiconfig/k3r5-sr1-hs-fs.conf
@@ -0,0 +1,3 @@ 
+require k3r5-sr1.conf
+
+MACHINE_append = "-hs-fs"
diff --git a/conf/multiconfig/k3r5-sr1.conf b/conf/multiconfig/k3r5-sr1.conf
new file mode 100644
index 00000000..2b87de8a
--- /dev/null
+++ b/conf/multiconfig/k3r5-sr1.conf
@@ -0,0 +1,3 @@ 
+require k3r5.conf
+
+MACHINE_append = "-sr1"
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 0fb3a832..39e5907f 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -33,7 +33,8 @@  SYSFW_PREFIX_j7-hs-evm-k3r5 = "fs"
 SYSFW_PREFIX_j7-hs-evm-k3r5-sr1-1 = "fs"
 SYSFW_PREFIX_j7200-evm-k3r5 = "fs"
 SYSFW_PREFIX_j7200-hs-evm-k3r5 = "fs"
-SYSFW_PREFIX_j721s2-evm-k3r5 = "fs"
+SYSFW_PREFIX_j721s2-evm-k3r5-gp = "fs"
+SYSFW_PREFIX_j721s2-evm-k3r5-sr1-hs-fs = "fs"
 SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
 SYSFW_PREFIX_j784s4-evm-k3r5 = "fs"
 SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs"